Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 32
Registered: ‎05-21-2012
My Device: Bold 9900 & Playbook
My Carrier: Telus

code/content assist

Hey everyone,

 

Does anyone know how to fix the code/content assist? all of the options in the preferences menu look ok and content assist is working for what looks to be all of the #include elements except for anything in <bb/cascades/*>.

 

when I type in for example:

Container *myContainer = Container::  code assist appears with a whole bunch of options but create() isn't one of them.

 

also if I type myContainer->  content assist appears an only gives me one option "Container"

 

I can program away without content assist but I would like to have it back because it saves me time and I use it to tell if I spelled the variable named correctly.

 

I suppose I should mention that this seems to have happened after upgrading to beta 4. I have reinstalled 4 times and tried it on a different computer with a different operating system.

 

Thanks,

 

Bryce

Developer
Posts: 1,746
Registered: ‎04-08-2010
My Device: Passport Silver, PRIV
My Carrier: Telekom.de, O2, Vodafone

Re: code/content assist

I had some problems with new classes and fixed it by re-indexing:

rightclick project -> index -> rebuild

(thx Kyle Fowler for this tip via Twitter)

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development native Mobile Business Apps
BlackBerry 10 | Qt Mobile (Android, iOS)
Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org
mobile-development: http://appbus.org Twitter: @ekkescorner
Highlighted
Developer
Posts: 16,998
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: code/content assist

another option would be that a content assist is turned off.
check preferences/c++/editor/content assist, then control the checkboxes in the advancd section.
installing the new beta removed a check there for me (but not for my colleague)
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter