Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 112
Registered: ‎04-28-2010
My Device: 8520
My Carrier: AirTel
Accepted Solution

getting problem when starting native/cascades sdk beta- "QML preview is not available"

hello friends,

 

when i am starting native/cascades sdk beta(latest version). It showing a error message "QML previw is not available". I am attaching the screen shot of this also. And my PC has no external graphics card.

 

Please tell me why i am getting this message?

 

Thanks & Regards,

dinesh

Developer
Posts: 112
Registered: ‎04-28-2010
My Device: 8520
My Carrier: AirTel

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

and at native sdk when i am working on .qml, the options "design mode", "Horizontal Split Mode" and "Vertical Split Mode" are also not working.
Retired
Posts: 19
Registered: ‎05-07-2012
My Device: none
My Carrier: none

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

Hello dinesh,

It sounds like you do not have a graphics device that supports preview mode. You need to have a reasonably modern graphics chipset with sufficient openGL support to use the live preview in Momentics. Specifics can be found in the "Cascades Builder" section at https://developer.blackberry.com/cascades/download/releasenotes/. Unfortunately, unless you upgrade your graphics card,  you will probably have to use the simulator or a device to view your UI.

Tim

 

Developer
Posts: 146
Registered: ‎05-18-2012
My Device: PlayBook & STL100-1 LE Z10 & Dev Alpha C
My Carrier: Telefonica Spain

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

Timvito, why not to elaborate a list with knowed unsupported graphic cards?  ( a wiki list make by revs, of course).

 

This problem is very annoying. 

---------------------------------------------------------------
Leandro Cerdan - Duantox Apps
BlackBerry Elite dev
TapyHold, Built for Blackberry multimedia scrapbook
Developer
Posts: 112
Registered: ‎04-28-2010
My Device: 8520
My Carrier: AirTel

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

Hello timvito,

 

Thanks for reply,

Can u provide us minimum requirement of graphics card by memory/version/manufecturer.

 

Thanks & Regards,

Dinesh Aggarwal

Retired
Posts: 19
Registered: ‎05-07-2012
My Device: none
My Carrier: none

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

Hey Dinesh and blackqtcoder,

The QML preview requires a graphics card that supports 3-D acceleration and OpenGL 2.0 support., so that would be nVidia Geforce FX (5) and up, and ATi Radeon HD 2xxx series and up. More information about whether specific chipsets have opengl 2.0 support can be found at http://en.wikipedia.org/wiki/Comparison_of_Intel_graphics_processing_units.

Tim

Developer
Posts: 146
Registered: ‎05-18-2012
My Device: PlayBook & STL100-1 LE Z10 & Dev Alpha C
My Carrier: Telefonica Spain

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

Thanks, timvito. We love you ;-)
---------------------------------------------------------------
Leandro Cerdan - Duantox Apps
BlackBerry Elite dev
TapyHold, Built for Blackberry multimedia scrapbook
Highlighted
Developer
Posts: 112
Registered: ‎04-28-2010
My Device: 8520
My Carrier: AirTel

Re: getting problem when starting native/cascades sdk beta- "QML preview is not available"

thanks timvito, have a nice day!