Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ
Accepted Solution

std/stl errors using newer NDK

[ Edited ]


I'm having some build issues since switching to the new 10.2 Momentics.app on OSX. The same source used to build fine ont he older QDE. App source: http://git.io/8L_cxw


The errors appear to be std/stl related and used in QT files.


Full build log: http://pastebin.com/kNGtawgG


In file included from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/cpp/xmemory:9:0,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/cpp/memory:7,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/cpp/algorithm:6,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/qt4/QtCore/qglobal.h:68,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/qt4/QtCore/qatomic.h:45,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/qt4/QtCore/qvariant.h:45,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/qt4/QtCore/QVariant:1,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/bb/cascades/controls/container.h:6,
                 from /Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/bb/cascades/Container:1,
                 from ../src/BrightnessBarView.h:19,
                 from ../src/BrightnessBarView.cpp:16:
/Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/cpp/xutility:1281:10: error: 'basic_streambuf' does not name a type
/Applications/Momentics.app/target_10_2_0_339/qnx6/usr/include/cpp/xutility:1282:10: error: 'basic_istream' does not name a type



Posts: 135
Registered: ‎11-14-2010
My Device: BlackBerry Z10 (White)
My Carrier: Vodafone

Re: std/stl errors using newer NDK

Could it be that you didn't update your DYLD_LIBRARY_PATH? If so, check out the upgrade guide here:



Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ

Re: std/stl errors using newer NDK

I don't have DYLD_LIBRARY_PATH set anywhere. What is $STAGE_DIR coming from? With 10.0.? QDE I used to call the environment.sh or whatever it was called (included with the ndk package), but this new version is a .APP, so I just took that out of my .bash_profile. If there is manual setup required with this new 10.2 Momentics its not obvious.

BlackBerry Development Advisor
Posts: 15,887
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: std/stl errors using newer NDK

We weren't able to reproduce this.  Can you confirm that you have 10.2 set as your API level?  To verify open the BlackBerry Native SDK, click on Window -> Preferences and search for API.


If it is it's likely environmental, e.g. pulling in a header from another target somehow.  It's hard determine the cause based on the error message.  Can you compile that single source file with the -E (writes to stdout) or -P (writes to a <file>.ii) option to generate the preprocessed output?  It will include all the line info and path info for the headers and source file.  That may help us untangle what's happening.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ

Re: std/stl errors using newer NDK

[ Edited ]

Thanks for the response. Since I can build a newly created project I figure it was just project related and not environment based. Going on that assumption I just replaced the .project and .cproject with what was generated by the newer project. After updating to those I am now able to build using any of the API levels (all API levels were failing on this project, not just 10.2). If you guys want to debug it, the changes are in Github now (heres the commit: https://github.com/hardisonbrewing/ColorWheel/commit/1a80986141f3e85e9a527f4d44d18496042aafe6).