Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 8
Registered: ‎08-17-2013
My Device: Q10
My Carrier: AT&T
Accepted Solution

[ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

Hello Everyone,

 

I'm running on to a problem when creating a new cascades project on the new released 10.2 ndk. As soon as I get to the API level, it states that none is installed, but all of them are (10.0, 10.1, 10.2).

 

no installed APIs

 

Installed APIs

 

I'm running:

 

Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

 

QNX® Momentics® IDE for BlackBerry® 10 Native SDK

Version: 10.2.1
Build id: v201308081807

 

If anyone has run into this issue or knows a solution, please let me know; any help is appreciated.

 

Thanks in advance,

 

ampz9

New Developer
Posts: 8
Registered: ‎08-17-2013
My Device: Q10
My Carrier: AT&T

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

Solved it by uninstalling the ndk (one more time as I had attempted this several times) and instead of setting it up using the wizard, I downloaded the API level when creating my bb project...

Developer
Posts: 127
Registered: ‎07-02-2013
My Device: Q10 v10.3.1.1565
My Carrier: {unbranded}

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

hello,

 

I have exactly same issue. have installed API levels, but when creating project the wizard says:

"No API Levels found. The new project wizard requires an API Level to proceed."

 

i have tried to uninstall and reinstall bbndk, but seems it remembers installed API levels.

any clue how to fix problem?

 

os: debian wheeze

bbndk: BB10_2_0X-1155-106-201308081646

New Member
Posts: 1
Registered: ‎10-09-2013
My Device: Blackberry Q5
My Carrier: Virgin

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

I managed to overcome the problem by installing the native sdk into my home directory instead of running the installer with sudo and installing into /opt.

New Developer
Posts: 4
Registered: ‎11-01-2013
My Device: Z10 STL100-2
My Carrier: congstar

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

Hello,

 

i have the same problem.

I have installed as root (sudo ...) and cannot use it as normal user. (No API Levels found. ...)

Using as root works.

So, it is a permmision problem.

 

I do not want to install this in my home directory and of course i do not want to use it as root.

 

Any suggestions?

 

-Michael

 

 

 

Highlighted
New Developer
Posts: 4
Registered: ‎11-01-2013
My Device: Z10 STL100-2
My Carrier: congstar

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

Hi,

 

is nobody else interested, to solve this issue.

Are you all developing as root or do you install everything in your home directory.

 

The platform, wanting to by more secure than others, forces develpers building their apps as root.

It's a joke, isn't it?

 

-Michael

 

 

 

New Developer
Posts: 12
Registered: ‎05-28-2014
My Device: Z10
My Carrier: Vodafone

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

[ Edited ]

I solved this by running the momentics installer without sudo.

New Developer
Posts: 4
Registered: ‎11-01-2013
My Device: Z10 STL100-2
My Carrier: congstar

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.


DrKaoliN wrote:

I solved this by running the momentics installer without sudo.


So you have installed to your home directory, right?

If so, there is nothing solved.

 

 

 

 

 

 

 

New Developer
Posts: 12
Registered: ‎05-28-2014
My Device: Z10
My Carrier: Vodafone

Re: [ubuntu] No API Levels found. The new project wizard requires an API Level to proceed.

No, I have installed it in my ~/Downloads folder.

The thing is that I don't get this error anymore. I can install the API Levels.