Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Regular Contributor
Posts: 52
Registered: ‎02-08-2013
My Device: Z10
My Carrier: Rogers
Accepted Solution

warning when running wizard generated Cascades project on device

bbndk 10.

 

(1) New->BlackBerry Project->Cascases->Tabbed Pane project

 

(2) build and run the app on device

 

(3) some warnings printe out in console

 

MsgNak received - resending
Remote target is little-endian

 

warning: .dynamic section for "/home/robin/bbndk/target_10_0_9_1673/qnx6/armle-v7/usr/lib/libcertmgr_client.so.1" is not at the expected address (wrong library or version mismatch?)

 

warning: Could not load shared library symbols for libusc.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for libsrv_um.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for libpvr2d.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for libIMGegl.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for wsegl-screen.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for libImgGLESv2.so.
Do you need "set solib-search-path" or "set sysroot"?

 

warning: Could not load shared library symbols for img_codec_png.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for libglslcompiler.so.
Do you need "set solib-search-path" or "set sysroot"?

 

How to fix the warnings? 

Developer
Posts: 1,524
Registered: ‎12-18-2012
My Device: Z30, Z10 LE, DevAlpha C, PlayBook

Re: warning when running wizard generated Cascades project on device

[ Edited ]

1673 is an old version. I believe the most recent one is 10_0_9_2372.

Upgrade to the latest SDK by clicking "Update Native SDK" button on the toolbar. If the button isn't there you might have to download the latest SDK from the website to perform the update. Also make sure that the device's firmware is up to date.


Andrey Fidrya, @zmeyc on twitter
Regular Contributor
Posts: 52
Registered: ‎02-08-2013
My Device: Z10
My Carrier: Rogers

Re: warning when running wizard generated Cascades project on device

So the official SDK release is not good? I try to avoid to use Alpha release.

 

and how to upgrade FW of device?

Developer
Posts: 1,524
Registered: ‎12-18-2012
My Device: Z30, Z10 LE, DevAlpha C, PlayBook

Re: warning when running wizard generated Cascades project on device

I think they are official too, but the upgrade process was automated. The version on the website is not the most recent one, you have to upgrade it from Momentics.

 

SDK for devices with HW keyboard is in Beta though. It's downloaded separately.

 

 

Device software can be upgraded using autoloader:

http://developer.blackberry.com/blackberry10devalpha/devalpha_update.html 

Or from the device itself in Settings -> Software Updates.

 


Andrey Fidrya, @zmeyc on twitter
Regular Contributor
Posts: 52
Registered: ‎02-08-2013
My Device: Z10
My Carrier: Rogers

Re: warning when running wizard generated Cascades project on device

I download Dev Alpha AutoLoader from http://developer.blackberry.com/blackberry10devalpha/devalpha_update.html

 

And follow up update step there: I got the error:

 

C:\>Autoload-DevAlpha-10.0.10.263.exe
RIM Wireless Device Command-Line Auto-Programmer Version 3.10.0.15 (Win32) [Dec 20 2012 22:31:59]
Copyright 2012 Research In Motion Limited


Could not connect to BlackBerry Device Manager

 

Error: Could not connect to BlackBerry Device Manager

Developer
Posts: 1,524
Registered: ‎12-18-2012
My Device: Z30, Z10 LE, DevAlpha C, PlayBook

Re: warning when running wizard generated Cascades project on device

Does device offer to install a driver when plugged in? Installing Blackberry Desktop Software might also help.

Andrey Fidrya, @zmeyc on twitter
Regular Contributor
Posts: 52
Registered: ‎02-08-2013
My Device: Z10
My Carrier: Rogers

Re: warning when running wizard generated Cascades project on device

Yes. I also figured out by google. I need to install bblink.

Regular Contributor
Posts: 52
Registered: ‎02-08-2013
My Device: Z10
My Carrier: Rogers

Re: warning when running wizard generated Cascades project on device

Simliar warnings in the latest SDK on Windows 7, Not sure if we could ignore the warnings?

 

warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: .dynamic section for "C:\\bbndk\\target_10_0_10_261\\qnx6\\x86\\usr\\lib/libstrpattern.so.1" is not at the expected address (wrong library or version mismatch?)
warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: Corrupted shared library list: 0x0 != 0x868cc00

 

warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: Could not load shared library symbols for libHwEGL.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: Could not load shared library symbols for 3 libraries, e.g. libegl_gallium.so.
Use the "info sharedlibrary" command to see the complete listing.
Do you need "set solib-search-path" or "set sysroot"?

 

warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: Could not load shared library symbols for libHwGLESv2.so.
Do you need "set solib-search-path" or "set sysroot"?

 

warning: Corrupted shared library list: 0x0 != 0x868cc00
warning: Could not load shared library symbols for img_codec_png.so.
Do you need "set solib-search-path" or "set sysroot"?