Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Visitor
Posts: 1
Registered: ‎10-06-2010
My Device: Curve 8520
My Carrier: Vodafone

API failure (DE372) on simulator: an unsupported api was called : rimwlanreqturbostart

Hello,

I have been trying and using few of our application on BB platforms. As in current deployment env is behind the HTTP Proxy, I followed the steps mentioned in  BlackBerry Support  to setup the proxy in BB Simulator. But after the proxy setup, whenever I try and browse through browser, it throws and error API failure (DE372): an unsupported api was called : rimwlanreqturbostart.

 

Well any thought, suggestion, work around and solution is welcome.

 

It has also generated a bug report, but I'm unaware that blackberry provides a BugReporting system to users.

 

 

Thanks.

BlackBerry Development Advisor
Posts: 15,888
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: API failure (DE372) on simulator: an unsupported api was called : rimwlanreqturbostart

[ Edited ]

What BlackBerry Smartphone model and BlackBerry device software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

 

Please verify that the version of DirectX installed on your PC is up to date.

 

Try closing the BlackBerry smartphone simulator, running the clean.bat file located in the simulator directory and start the simulator again.  Once the simulator has started up, disable the WiFi radio before trying to browse.

 

 

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.