Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Contributor
Posts: 24
Registered: ‎11-06-2009
My Device: Not Specified

Activating simulators with BES5 (Domino)

[ Edited ]

I try to activate simulators with BES 5.0.1 MR1 on Lotus Domino 8.5.1 so far without success.

 

All the documentation I found from RIM descripe the process using the Desktop Manager (and BES 4.1.6) . Is it not possible to activate the simulator directly via virtual USB cable connection to BAS?

 

The simulator will be detected as connected from BAS and all device informations (-> device properties) are displayed, but then, if I try to activate the simulator device I only get an error message from BAS which claims to be unable to fetch device informations. Very strange.

 

I tried the following combinations:

9700 simulators OS5 (US & EU), running on Windows XP, Vista and 7 (all 32-Bit).

 

Any ideas for further debugging ? Where might I find official documentation from RIM?

 

Thanks in advance,

Peter

 

Addition: I get one step further: After reactivating DIIOP (task was gone on my test system), BAS seems to be able to assign the device to an user, but this end on the simulator with:

"JVM Error 104 Uncaught: Nullpointer Exception"

Simulators tried in this case: 9700-T-MobileUS 5.0.0.400 and 9700-T-MobileEU 5.0.0.330 (I assigned unique PINs)

 

BlackBerry Development Advisor
Posts: 15,698
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Activating simulators with BES5 (Domino)

Are you able to continue past the JVM 104 error (by clicking Continue or the Run button in Eclipse/JDE)?  You may need to press this multiple times if multiple exceptions are thrown.

 

You shouldn't see a JVM 104 error on an actual BlackBerry Smartphone.  They are thrown within the BlackBerry smartphone simulator to aid in debugging.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
Contributor
Posts: 24
Registered: ‎11-06-2009
My Device: Not Specified

Re: Activating simulators with BES5 (Domino) - solved

> Is it not possible to activate the simulator directly via virtual USB cable connection to BAS?

 

First: Yes, it is possible! It seems not really necessary to use the Desktop Manager (did I overseen something about it in the documentation?)

 

Pressing "continue" after the JVM message did really continue the process ;-)

 

The cause of my problem was another one: My test environment was broken. Even activating a real device via usb did not work anymore. Maybe after assigning the standalone server into AD and then reinstalling BES something has gone wrong. I removed BES carefully from the system and reinstalled it from scratch. Now everthing seems to be fine so far ...

 

Thank you for your help!

 

Peter