Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

New Contributor
Posts: 4
Registered: ‎08-18-2013
My Device: Q10 SQN100-1
My Carrier: Bell Mobility

App Permission Request always fail

Hi, I'm new here, this is possible that my post is in the wrong place...


I've tried many times to request permission for headless application but nothing happen when I click on Submit button. I finally verified in Firefox console and I receive this error :


<br /><b>Warning</b>:  oci_execute() [<a href='function.oci-execute'>function.oci-execute</a>]: ORA-01400: cannot insert NULL into (&quot;APPTEST&quot;.&quot;HEADLESSREG&quot;.&quot;VENDORID&quot;) in <b>/opt/sites/jam/lib/vettingdb.php</b> on line <b>64</b><br />{"status":"error","message":"An error occured saving to the database. Please try again later."}

Any fix on that?


Here is the URL used : https://developer.blackberry.com/jam/headless/register.php


Thank you,


BlackBerry Development Advisor
Posts: 15,759
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: App Permission Request always fail

This was fixed on Monday.  Let me know if you still have any issues with the form.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker