Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Member
Posts: 1
Registered: ‎10-17-2011
My Device: Curve
My Carrier: Claro

App Signing success, but the Signature Tool keep showing NOT SIGNED

Hi, I'm new in the forum

 

I got this problem, I create a simple app for the the Blackberry, I got no problem when I build it, then I use the Signature Tool, make the request, submit my private key, then show me a window that tell "Signing Complete 2/2", I receive the mail telling me that the app is signed.

 

But when I used in the Blackberry it show me this error "Error starting MYAPP: Module ‘MYAPP’ attempts to access a secure APL"

 

I check again the signature tool and I'm surprised that it says "NOT SIGNED", I make a research, but I can't find the solution, please help

Highlighted
BlackBerry Development Advisor
Posts: 15,700
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: App Signing success, but the Signature Tool keep showing NOT SIGNED

This can happen if the COD file you are trying to sign or the directory it is located in is read only.  The tool will attempt to sign (and think it successful), but it fails to write the signatures to the COD file.

 

Ensure that you have write permissions to the file/directory and/or move the project to a different location.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker