Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Contributor
Posts: 29
Registered: ‎04-26-2011
My Device: Z10, Torch 9800, PlayBook 16GB
My Carrier: Rogers
Accepted Solution

App wont install on Z10 when Icon & Splash Screen images are added in Bar Descriptor

Hi - Not sure if this is an unusual issue, but my app wont install/load onto my Z10 when either or both of the Icon & Splash Screen images are added in Bar Descriptor file.  I have development mode on, and do have a debug token installed and it's still valid.  The strange thing is that the app will install on the simulator without issue.

 

If I remove the Icon & Splash Screen images from the Bar Descriptor file, the app loads onto my Z10 successfully.

 

The images are the correct sizes: 114x114 px for the Icon, and 768x1280 px for the SplashScreen.  The Momentics IDE accepts both files by placing check-marks beside them.  I have also tried adding the images for the PlayBook & Q10, and still no luck with loading it onto my device.  I even tried reverting back to the default image for the icon, and that no longer works either.

 

The error i get when trying to install my app onto my Z10 with the Icon & Splash Screen images is:

 

Deployment Failed: Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: Debug native: on
Info: File size: 414105
Info: Installing com.example.ProfitCalc.testDev__ProfitCalc9866a36a...
Info: Processing 414105 bytes

 

Anyone have any ideas why this is happening??

 

Thanks.


--------------------------------------------------------------------------------------------------
Please click 'Like' if this was helpful, and mark it as a solution if it has solved your problem.
BlackBerry Development Advisor
Posts: 15,700
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: App wont install on Z10 when Icon & Splash Screen images are added in Bar Descriptor

This is a known issue with some releases of BlackBerry OS 10.1.  This article explains the issue and provides a workaround. 

 

Application Deployment may hang or fail after OTA Update to 10.1.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
Contributor
Posts: 29
Registered: ‎04-26-2011
My Device: Z10, Torch 9800, PlayBook 16GB
My Carrier: Rogers

Re: App wont install on Z10 when Icon & Splash Screen images are added in Bar Descriptor

Thanks Mark.  If I dont use the script method described by the article the link points to, can I still launch my app to BB World and not be worried of this issue causing a problem when the app is under review??  The app and images load fine on the simulator.

 

Thanks again!


--------------------------------------------------------------------------------------------------
Please click 'Like' if this was helpful, and mark it as a solution if it has solved your problem.
BlackBerry Development Advisor
Posts: 15,700
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: App wont install on Z10 when Icon & Splash Screen images are added in Bar Descriptor

Correct.  This doesn't affect applications being installed from BlackBerry World.  It just affects side loading them.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker