Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Highlighted
New Contributor
Posts: 7
Registered: ‎11-30-2010
My Device: Bold 9700 & Storm 9550
Accepted Solution

BB Dev Alpha - another problem after security wipe

At first, the device lost ability to connect to the PCs (it wasn't recognized on any of the computers it was connected to).

So I decided to do a security wipe. After the wipe every time the phone tried to load the operating system, the progress reached 100% and stopped. I've downloaded the autoloader driver DevAlpha A/B 10.1.0.1485 and tried to reinstall the operating system with its help, but it refused to install with error messages "OS does not match hardware", "This file does not match this device".Then I've downloaded an older version of dev alpha drivers (autoloader DevAlpha 10.0.10.263), but it got the same errors.

After these update attempts the device reaches 100% boot progress and then reboots, once and once again. Link Software can't start the firmware recovery process. It's also interesting that the device's hardware ID isn't listed here.

 

I've read a number of topics about similar DevAlpha problems on support forums, but some of the solutions are outdated, and others don't work for my device. Can anyone give any advice? Thanks

 

P.S. Here's the log from 10.1.0.1485 driver:

 

C:\Downloads\Programs>Autoload-DevAlphaA_B-10.1.0.1485
RIM Wireless Device Command-Line Auto-Programmer Version 3.10.0.29 (Win32) [Apr
 1 2013 19:59:10]
Copyright 2012 Research In Motion Limited

Connecting to Bootrom:
Resetting Device: Connected

[       Uploading RAM Image 0x80238984 ] [############## 100 ##############]

QCFMv1/v2 Hybrid File
    containing: Radio

    Signature Trailer:
       EC521_512 Signer: 0x48584E51 (QNXH-OS-1)
       EC521_256 Signer: 0x4C584E51 (QNXL-OS-1)
[                  Writing  0x006E0000 ] [############## 100 ##############]

QCFMv1/v2 Hybrid File
    containing: IFS, OS, User File System

    IFS/OS Version:        10.1.0.1485 DEV
        Hardware ID:       0x06001A06 RIM BlackBerry Device
        Metrics Version:   3.18
        Build Date:        Apr 13 2013
        Build Time:        10:23:20
        Build User:        ec_agent
        STP Protocol Ver:  0.0.4 (release OS)

    Signature Trailer:
       EC521_512 Signer: 0x48584E51 (QNXH-OS-1)
       EC521_256 Signer: 0x4C584E51 (QNXL-OS-1)
--> OS does not match hardware. (C: 0X06001A06 H: 0X8500240A O: 0X051D0001 )


Error: Failed to load images.


Error: This file does not match this device!

 And here's the log from 10.0.10.263:

C:\Downloads\Programs>Autoload-DevAlpha-10.0.10.263.exe
RIM Wireless Device Command-Line Auto-Programmer Version 3.10.0.15 (Win32) [Dec
20 2012 22:31:59]
Copyright 2012 Research In Motion Limited

Connecting to Bootrom:
Resetting Device: Connected

[       Uploading RAM Image 0x8022E584 ] [############## 100 ##############]

QCFMv1/v2 Hybrid File
    containing: IFS, OS, User File System

    IFS/OS Version:        10.0.10.263 DEV
        Hardware ID:       0x06001A06 RIM BlackBerry Device
        Metrics Version:   3.18
        Build Date:        Jan 27 2013
        Build Time:        11:33:05
        Build User:        ec_agent
        STP Protocol Ver:  0.0.4 (release OS)

    Header Version:        2.0
       Num Chunk Headers:  6
       Headers Length:     65120

    Chunk Header:
       Type:          0x06
    Chunk Header:
       Type:          0x08
    Chunk Header:
       Type:          0x06
    Chunk Header:
       Type:          0x05
    Chunk Header:
       Type:          0x09
    Chunk Header:
       Type:          0x89
    Signature Trailer:
       EC521_512 Signer: 0x48584E51 (QNXH-OS-1)
       EC521_256 Signer: 0x4C584E51 (QNXL-OS-1)
--> OS does not match hardware. (C: 0X06001A06 H: 0X8500240A O: 0X051D0001 )


Error: Failed to load images.


Error: This file does not match this device!

 

Developer
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: BB Dev Alpha - another problem after security wipe

Do you've been running full Z10 os before on your dev alpha ?
New Contributor
Posts: 7
Registered: ‎11-30-2010
My Device: Bold 9700 & Storm 9550

Re: BB Dev Alpha - another problem after security wipe

borceg, to be honest, I don't know the differences because didn't have a chance to compare it to the market version. But the phone had a progress bar in form of blue square with rounded corners (on the startup screen), and AFAIR the release version should have another logo, so maybe my os was incomplete

Developer
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: BB Dev Alpha - another problem after security wipe

That mean you were running full z10 os on your dev alpha b. In order to successfully flash any other version to it, make sure to download Z10 STL100-1 autoloader, not Dev Alpha B one.
New Contributor
Posts: 7
Registered: ‎11-30-2010
My Device: Bold 9700 & Storm 9550

Re: BB Dev Alpha - another problem after security wipe

Thank you very much! I'll respond after trying to fix it

New Contributor
Posts: 7
Registered: ‎11-30-2010
My Device: Bold 9700 & Storm 9550

Re: BB Dev Alpha - another problem after security wipe

Thanks again! It worked fine, everything is OK now