Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Posts: 648
Registered: ‎09-26-2012
My Device: Limited Edition Z10, Playbook 16GB/32GB, Dev Alpha A/B/C
My Carrier: Mobile Vikings
Accepted Solution

BlackBerry 10 Dev Alpha device boot loop

I have an BlackBerry 10 Dev Alpha device on which I wanted to test an application I made. But it resulted in a device that doesn't want to boot anymore. It stops the boot on the "BlackBerry 10 Dev Alpha" boot screen every time. I cannot start the device like it should.
What I did to have this bug?
I had Dev alpha 10.0.6 - 671 installed on my device. I put my device in dev mode, because I needed to upload my application from my pc to the phone. That worked all fine. The application installed successfully, but then the problems started. The application crashed or something, because the phone just froze. I couldn't do anything anymore (not even swiping from corners or bottom). So I thought it would be fixed if restarted my phone. But that wasn't the case.
When I now want to start the device, it stops on the "BlackBerry 10 Dev Alpha" boot screen. It doesn't freeze or anything, because the background keeps changing. But the OS doesn't continue (I've let it 'start' for a whole night and it was still on the same window). When I want to restart or shut it down, it doesn't work because the screen goes blank for about a second and then the boot screen appears again, but doesn't disappear... So I cannot actually shut the device down..
What have I tried to solve the problem?
  • I have tried to just reboot by holding all the possible hardware keys, but without any luck.
  • I have tried to connect to my pc and repair with BlackBerry Desktop Software. But the last update of the Dev Alpha doesn't want to install (the one announced on 25th September 2012). It says that the update should be installed, but it doesn't fix the problem and when I disconnect and reconnect my device it says again that the same update is available. So apparently the update isn't installed like the Desktop Software says it is.

I would really like to 'unbrick' my device so I can test my application on a real device. 

Any help is appreciated !

A like is always appreciated,
but a nomination for BB Elite even more :-)
You can also contact me on Twitter: @ndsmyter
Posts: 96,067
Likes: 24,621
Solutions: 6,421
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: BlackBerry 10 Dev Alpha device boot loop

Then you should be posting in the developer section of this forum.


Read this: http://supportforums.blackberry.com/t5/Testing-and-Deployment/Do-not-wipe-Dev-Alpha-Update-10-0-9-Bu...


Please don't repost, we'll get this thread moved there.

1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Posts: 22
Registered: ‎08-17-2012
My Device: Z10 Limited Edition
My Carrier: Telcel

Re: BlackBerry 10 Dev Alpha device boot loop

i got the same issue but i kind of find a solution here my Dev aso looped when i tried to boot it but this only hapened qhen i unplugged the charger.


Try it, boot your devide WITHOUT unplugging the charger, that worked for me several times. HOpe it works for you.

New Developer
Posts: 7
Registered: ‎12-19-2010
My Device: Style
My Carrier: Sprint

Re: BlackBerry 10 Dev Alpha device boot loop

Same thing happened to me. I think the problem was that the battery died, and it required a little bit of a charge before it will fully boot up. Best thing to do is to charge it up for awhile before turning on the device.