Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Highlighted
New Developer
Posts: 75
Registered: ‎08-15-2013
My Device: blackberry curve 9630
My Carrier: Airtel

Blackberry Q10 device not getting auto discovered in QNX momentics IDE

Hi All,

 

I am deploying cascades application on blackberry q10 device.  When i connect my device to computer using blackberry link software the device is getting connect to laptop and is also displayed in My Computer Screen. However when i try to discover that device from QNX momentics IDE its not getting displayed.

 

However blackberry Z10 is successfully detected by the QNX and app runs on Z10 but in case of Q10 momentics cannot discover it.  Both devices have blackberry 10.1 OS installed and have development mode enabled before connecting them to laptop.  I have also restarted Q10 and reconnected but still it did not work.

 

Please help where i am going wrong.

 

Thanks & Regards

BlackBerry Development Advisor
Posts: 15,808
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Blackberry Q10 device not getting auto discovered in QNX momentics IDE

Try to close BlackBerry Link before discovering the device in Momentics.  Having both attempt to connect to the device at the same time can cause conflicts.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Developer
Posts: 75
Registered: ‎08-15-2013
My Device: blackberry curve 9630
My Carrier: Airtel

Re: Blackberry Q10 device not getting auto discovered in QNX momentics IDE

Hi,

 

I tried that but still its not working. Also Blackberry Device Manager is detecting the blackberry Q5 device but QNX momentics is not.

 

Aso cross checked all settings in device to make sure they are correct, but still ii am not able to connect it to QNX momentics IDE under "Add Target"option when we run app as Blackberry application.

 

Please help me whats going wrong here.

 

Thanks & Regards,

Tushar

BlackBerry Development Advisor
Posts: 15,808
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Blackberry Q10 device not getting auto discovered in QNX momentics IDE

Are you using auto detect or specifying the address?  If auto detect is failing try using the IP of 169.254.0.1.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.