Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎07-18-2013
My Device: Z10 STL100-1

Can't SSH into Z10 - asks for key password

Hi guys,

I'm working on Linux and I'm having some troubles connection via SSH to my Z10 device. Here's what I've done so far:

 

1) Enable USB networking. I can ping an dport scan the Z10 from my Linux laptop.

2) Install Momentics IDE

3) Obtain signing keys and create debugtoken

4) Install debugtoken on device

5) Rebooted & re-enabled development mode

6) Generate a 4096 bit key for SSH

$ ssh-keygen -t rsa -b 4096
Generating public/private rsa key pair.
Enter file in which to save the key (/home/atodorov/.ssh/id_rsa): /home/atodorov/.rim/testKey_4096_rsa
/home/atodorov/.rim/testKey_4096_rsa already exists.
Overwrite (y/n)? y
Enter passphrase (empty for no passphrase):
Enter same passphrase again:
Your identification has been saved in /home/atodorov/.rim/testKey_4096_rsa.
Your public key has been saved in /home/atodorov/.rim/testKey_4096_rsa.pub.
The key fingerprint is:
77:73:55:03:e1:fc:5b:df:a6:e9:2c:b4:d4:1e:0c:b2 atodorov@redbull.mini
The key's randomart image is:
+--[ RSA 4096]----+
|             oo..|
|            o   o|
|             o  .|
|          . . .. |
|        S .oo+...|
|         .E.oo+ =|
|           o o o+|
|            o..+ |
|             o=  |
+-----------------+


7) Update key permissions, since ssh complains:


$ chmod 600 testKey_4096_rsa.pub



8) Use blackberry-connect to start the SSH daemon on the device:

$ pwd
/home/atodorov/bbndk/host_10_1_0_231/linux/x86/usr/bin

$ ./blackberry-connect 169.254.0.1 -devicePassword 12qwas
Info: Connecting to target 169.254.0.1:4455
Error: Error receiving data.
Error: A network error occurred while communicating with the target.
[atodorov@redbull bin]$ ./blackberry-connect 169.254.0.1 -devicePassword 12qwas -sshPublicKey ~/.rim/testKey_4096_rsa.pub
Info: Connecting to target 169.254.0.1:4455
Info: Authenticating with target 169.254.0.1:4455
Info: Encryption parameters verified
Info: Authenticating with target credentials.
Info: Successfully authenticated with target credentials.
Info: Sending ssh key to target 169.254.0.1:4455
Info: ssh key successfully transferred.
Info: Successfully connected. This application must remain running in order to use debug tools. Exiting the application will terminate this connection.


^^^ All appears correct.

9) Check if SSH is running on the device


$ nmap 169.254.0.1

Starting Nmap 5.51 ( http://nmap.org ) at 2013-07-18 10:19 EEST
Stats: 0:00:01 elapsed; 0 hosts completed (1 up), 1 undergoing Connect Scan
Connect Scan Timing: About 14.30% done; ETC: 10:20 (0:00:06 remaining)
Nmap scan report for 169.254.0.1
Host is up (0.00097s latency).
Not shown: 991 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
80/tcp   open  http
139/tcp  open  netbios-ssn
443/tcp  open  https
445/tcp  open  microsoft-ds
1111/tcp open  lmsocialserver
5555/tcp open  freeciv
8000/tcp open  http-alt
8443/tcp open  https-alt

Nmap done: 1 IP address (1 host up) scanned in 12.47 seconds

 

 

As you can see I have everything up and running until now.

 

10)  Use SSH with the specified key to connect to the Z10:

 

$ ssh -i ~/.rim/testKey_4096_rsa.pub  devuser@169.254.0.1
Enter passphrase for key '/home/atodorov/.rim/testKey_4096_rsa.pub':

 

 

Here's the problem - this will always ask me for a key password. I tried keys without password, I tried entering the key password, the device password, or any other password I know. No luck.

 

 

How do I fix this? Any ideas ?

 

Thanks!

 

 

 

--
http://atodorov.org
New Contributor
Posts: 3
Registered: ‎07-18-2013
My Device: Z10 STL100-1

Re: Can't SSH into Z10 - asks for key password

SOLVED it myself. ssh -i should have used the private key file, not the .pub one. Rookie mistake.

 

 

--
http://atodorov.org