Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
Posts: 5
Registered: ‎05-10-2011
My Device: Curve 8500
My Carrier: Airtel

Debugger detaching when connecting to a Blackberry Device

I tested my application on the emulator and it was working fine. The flow of the application is Splash Screen >> Login Screen >>..... . I uploaded the application on the device after signing it. When the application starts in debug mode the Splash screen appears and moves on to the Login screen but as soon as the login screen appears the debugger detaches. My device do not have a sim card and i am working with a wi-fi connection. Is it required to have a sim card inserted in the device? and also is it required to have the BB Services activated??

Contributor
Posts: 37
Registered: ‎07-26-2011
My Device: Non Blackberry User
My Carrier: Non Blackberry User

Re: Debugger detaching when connecting to a Blackberry Device

Are you using Eclipse debugger? If yes then once try using JDE debugger, it will help you.

Go to -> Start -> All programs -> Research In motion -> Blackberry JDE (one u r using) -> JDE

then in that windows click on -> Debug -> attached to -> Handheld device

 

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
1. Please press the kudos button (star icon) on the left side to thank the user that helped you.
2. Please mark posts as solved if you found a solution.
- Paresh Indulkar
(Game Programmer at Synqua Games)
(Developer of games - BBM Cricket with Friends & Word Poker with Friends Smiley Very Happy )
New Contributor
Posts: 5
Registered: ‎05-10-2011
My Device: Curve 8500
My Carrier: Airtel

Re: Debugger detaching when connecting to a Blackberry Device

Thank you Pri-Machine for your response. But my problem is that when i start  debugging my application, the application launches and i land on my Login page from here i take the username and password but then when i take the string from the BasicEditField.getText(), the values i get are null, and on inspecting the element i get exception as "Method "toString" with signature "()Ljava/lang/String;" is not applicable on this object"

Highlighted
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Debugger detaching when connecting to a Blackberry Device

A sim card and BlackBerry service is not required for debugging.

 

Have you installed a BlackBerry smartphone simulator that matches the OS version of your BlackBerry Smartphone?  Doing so installs the required debug files required for most debugging features.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker