Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Decrypt Keystore Password suddenly invalid?

[ Edited ]

Philipk wrote:
Working perfectly on both.

Are you deploying to BB10 with BB10 SDK or using the PlayBook SDK? For me signing for BB10 using the BB10 SDK breaks with the error you also reported earlier in the thread "Error: Failed to decrypt keystore, invalid password".


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Highlighted
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Decrypt Keystore Password suddenly invalid?

My almost complete console log looks like this:

 

...
[exec] [ERROR]   Error: Failed to decrypt keystore, invalid password
[exec] [ERROR]   Native Packager exception occurred
[exec] Info: Sending request: Install and Launch
[exec] Info: Action: Install and Launch
[exec] Info: File size: 4163161
[exec] Info: Installing MyAppName.testRel_MyAppName__983a34d1...
[exec] Info: Processing 4163161 bytes
[exec] actual_dname::
[exec] actual_id::
[exec] actual_version::
[exec] result::failure 881 required signatures missing (RDK, AUTHOR)

I reused the keys from PlayBook and followed the instructions in the documentation, also the point "Migrating to the BlackBerry 10 WebWorks SDK" but this was already done. I'm on Win32bit here.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Posts: 676
Registered: ‎05-06-2012
My Device: Dev Alpha & PlayBook
My Carrier: wifi

Re: Decrypt Keystore Password suddenly invalid?

I'm using the BlackBerry 10 WebWorks SDK and it's working for me. Did you try requesting new keys and setting them up again?
_________________________________________________________
co-founder of Diaree | BB Dev for PictureThis
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Decrypt Keystore Password suddenly invalid?

I'm going to give it a try with some new signing keys and I hope it works then!


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Posts: 676
Registered: ‎05-06-2012
My Device: Dev Alpha & PlayBook
My Carrier: wifi

Re: Decrypt Keystore Password suddenly invalid?

Let us know if it fixes the problem.
_________________________________________________________
co-founder of Diaree | BB Dev for PictureThis
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Decrypt Keystore Password suddenly invalid?

MMmhhhhh Ordered new keys, registered them successfully and now I can sign app for BB10 but can't sign for PlayBook anymore, it seems now the other way around like before with the following console output error:

 

...
[exec] [INFO]                      Starting signing tool
[exec] Error: Failed to decrypt keystore, invalid password
[exec] [ERROR]                     Signing failed
..

Something I missed to do?


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Decrypt Keystore Password suddenly invalid?

I tried again with the "old" keys working to sign on PB and the "new" keys working to sign on BB10 and I like previously mentioned depending on which of them used the keystore decryption fails on the other.

 

I also worked out that when changing them in the system folders I could go with the one next to the other, but I would need to change the folder where the signer is looking for them in my folder "C:\Users\Me\AppData\Local\Research In Motion" but this couldn't be the solution I think.

 

So what could be done?


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.