Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
Posts: 2
Registered: ‎08-27-2012
My Device: Playbook
My Carrier: None

Dev Alpha locked after update

Hey guys, I was updating my dev alpha for the latest and updated only when he was caught when he was restarting on again, he fought on the home screen and not only leaves only shows "BlackBerry 10 Dev Alpha" without animations, and I've tried connecting it with power + vol, the BlackBerry Desktop Software recognizes it and I try to restore but when it downloads the update and try to install it says it can not find the device that I do personally? help me: ((

Developer
Posts: 849
Registered: ‎03-03-2011
My Device: Z10

Re: Dev Alpha locked after update

I have the same issue. I tried unsuccessfully N times on 3 different PCs.
--------------------------------------------------------------------------------------
Leader of Ljubljana BlackBerry Developer Group
BlackBerry Certified Builder for Native Application Development
Developer
Posts: 314
Registered: ‎03-28-2012
My Device: Curve 9360, Playbook, BB10 Dev Alpha
My Carrier: TMN

Re: Dev Alpha locked after update

I'm living this drama too Smiley Sad

Without establishing a connection to the DM it really looks like a helpless situation... 

Any ideas?

Nuno
Trusted Contributor
Posts: 108
Registered: ‎01-18-2012
My Device: 9360
My Carrier: AIRTEL

Re: Dev Alpha locked after update

add me to the list..

Developer
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Dev Alpha locked after update

There are some updeate threads in the forum you can look at.

 

Try removing the developer password before doing updates.  Also set the connect to Windows / Mac options in the options menu.  Thats if you can access the device after doing the update.  Try also rebooting the device and NOT plugging it into pc.  Sometimes it needs to charge up first so leave it off for a while but plugged into usb.

 

Have a look at the other threads on updating problems.  It may help you.

If it helped you, click like. Smiley Happy
Developer
Posts: 849
Registered: ‎03-03-2011
My Device: Z10

Re: Dev Alpha locked after update

[ Edited ]

In case mentioned above password can't be removed.

In my case there were no password set.

 

And device doesn't charge anymore.

--------------------------------------------------------------------------------------
Leader of Ljubljana BlackBerry Developer Group
BlackBerry Certified Builder for Native Application Development
Developer
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Dev Alpha locked after update

Sorry to hear that.  I have seen other developers complaining about dead dev alpha's.

 

Does the device have a blinking red LED?  If so there is hope, some have managed to fix that.  Again search the forum, but I'm sure you did that already.

 

R.I.P dev alpha.

If it helped you, click like. Smiley Happy
Developer
Posts: 849
Registered: ‎03-03-2011
My Device: Z10

Re: Dev Alpha locked after update

No, my device doesn't blink. When it starts (plugged) it hangs on BlackBerry non-animated screen. Unplugged it is dead (I guess it doesn't charge).
--------------------------------------------------------------------------------------
Leader of Ljubljana BlackBerry Developer Group
BlackBerry Certified Builder for Native Application Development
New Contributor
Posts: 4
Registered: ‎08-25-2012
My Device: BB10 DevAlpha
My Carrier: +5511976362240

Re: Dev Alpha locked after update

I have the same problem here. I am considering the BB10 unit effectively bricked for now.

 

I have, however, dug a little more. I connected the device to a Linux host and it's alive enough to initiate a connection on the USB bus. From my syslog transcript:

 

 

Sep  4 21:35:34 lem kernel: [19997.543046] usb 3-1: new full-speed USB device number 2 using xhci_hcd
Sep  4 21:35:34 lem mtp-probe: checking bus 3, device 2: "/sys/devices/pci0000:00/0000:00:1c.4/0000:0b:00.0/usb3/3-1"
Sep  4 21:35:34 lem mtp-probe: bus: 3, device: 2 was not an MTP device
Sep  4 21:35:45 lem kernel: [20009.174668] usb 3-1: USB disconnect, device number 2
 
On a Windows XP machine (it died while being updated on a Mac, but I've set up another box to help narrow down the issue) it makes the USB connect and disconnect sounds.
 
The log on the Mac (from the BB desktop sw) is most interesting too.
 
 
I'm wasn't sure much beyond the USB interface is functional - the cycle could be completely automatic - but the log above makes me believe the device is, at least, booting partially before it disconnects and the BDQNXRecoverDeviceCommand fails.
 
Wish I knew more about QNX. I learned C on it (in 1987). Always had the utmost respect for it. Best proprietary OS ever.
Highlighted
Developer
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Dev Alpha locked after update

BTW - this thread was a slightly different problem but in my experience the SEQUENCE in which you do things is important.  Check out how he solved it, it may offer light.

 

http://supportforums.blackberry.com/t5/Testing-and-Deployment/BB10-Alpha-not-connecting-to-DM-on-Mac...

If it helped you, click like. Smiley Happy