Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 409
Registered: ‎06-13-2011
My Device: Z10, Playbook
My Carrier: Econet

Re: DevAlpha not updating on Desktop (Bundle 33) -

It will work, just be patient. which level is it failing? I have been having problems but after some research and findings i found a way and did the update. The solutions I provided in an earlier post are the ones i posted. try to unistall your Desktop Softwaree, clean the registry and start again.



Let us remember it is a Alpha device whilst at the same time the Desktop Software is in beta mode. Errors do occur.

Twitter: @IAmBenGiey | Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.

Try my apps:
The Ultimate Currency Converter and T2G - BloGFeed
New Developer
Posts: 20
Registered: ‎07-14-2012
My Device: Dev Alpha , Curev 9300
My Carrier: Vodafonee

Re: DevAlpha not updating on Desktop (Bundle 33) -

Okay everyone i have found the solution for the 1/6 red blinking.

Step 1: Stack charge for 30 times.


Step 2: While the charger plugged in push power button for 10 secs and keep repeating for 10 times.


Step 3: Attach the device to the computer start the desktop manager bundle 33 and choose the repair option.

**Note: It took me 3 days to figure this way out,the problem is that the os thinks the battery is dead/corrupt 

New Contributor
Posts: 7
Registered: ‎11-10-2010
My Device: BlackBerry 10 Dev Alpha
My Carrier: N/A

Re: DevAlpha not updating on Desktop (Bundle 33) -

Guys, I was update my Dev Alpha to up from 10.0.4 using a clean install of Desktop Software Plug device, restart, repair, update, wait, done!


The issue is that am trying now to update a second Dev Alpha from a team mate which is still This is what happens:


- Open DM.

- Connect the device and restart it. Windows rings the usual USB plug/unplug sounds.

- On restart DM says the usual Retry and Repair options and keeps waiting the device finish booting up.

- After a while, the device finishes booting up and later, DM says it could not connect.


Other symptoms:


- The device freezes showing a "Installing Drivers" banner (as the shown when USB-connected but other title).

- Windows Device Manager does not show any BlackBerry device connected.

- BlackBerry Device Manager does not show any device connected.

- DM says "unknown device".


I will do a full uninstall and clean install of DM, including all drivers and then try again.


Did anyone experienced the same issue? Any clues?



New Developer
Posts: 11
Registered: ‎08-11-2012
My Device: BB 10 DevAlpha
My Carrier: ChinaMobile

Re: DevAlpha not updating on Desktop (Bundle 33) -

Meet the same situation.

Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: DevAlpha not updating on Desktop (Bundle 33) -

I had similar troubles.  Also on 10.0.6.  I basically did the following...


1.  Removed desktop man with revo uninstaller

2.  Removed all other BB desktop related software and drivers - said yes to settings too.

3.  Downloaded fresh desktop bundle.

4.  Installed  BB D

5.  Plugged in phone for detection and did the whole setup for the phone.

6.  Did the restart / debrick method and said yes to the repair prompts.


I did however have to do this a few times before it worked.  Try also turning off the device (before attempting the debrick method) and starting it up fresh before connecting to BB D.  


Another thing, if you've been developing on the device TURN OFF the password protection and development modes before doing the update, I think it interferes.

If it helped you, click like. Smiley Happy
New Contributor
Posts: 7
Registered: ‎11-10-2010
My Device: BlackBerry 10 Dev Alpha
My Carrier: N/A

Re: DevAlpha not updating on Desktop (Bundle 33) -

All, my connection problem was solved changing "USB Connections" from "Automatically Detect" to "Connect to Windows" in "Storage & Sharing" options. Now I have both devices on!


Hope this helps!



Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: DevAlpha not updating on Desktop (Bundle 33) -

Well done, that does help.


I never had to change mine for some reason.  All good to know.

If it helped you, click like. Smiley Happy
New Member
Posts: 1
Registered: ‎08-25-2012
My Device: BB10 Dev Alpha
My Carrier: Fido

Re: DevAlpha not updating on Desktop (Bundle 33) -

I ran the security wipe and forgot to backup apps (camera app is missing herafter).


It looks like clean everything inside. With the camera apps is gone, development mode trun on but cannot install new apps. no longer response to ping.


Try to obtain new desktop software, with the USB cable, it does not hook up to the device.


I do not see the mass storage device as drive E: on my windows explorer. I am windows & professional service pack 1.


BB10 Device Alpha was on and was running fine in development mode before security wipe.


When connected by USB the BB10 dioes just to INstalling Drivers screen and stays there. Do I need a long long wait time before device connects.


I need to final test my app before publishing it. I need some help please. Thanks.



Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: DevAlpha not updating on Desktop (Bundle 33) -

Not being horrible but I think this is the wrong thread for this.


What I mean is you have problems which relate to other threads, for eg. try this:


It will get your dev alpha working on windows again.  From there try an update.


Also: http://supportforums.blackberry.com/t5/Testing-and-Deployment/BlackBerry-Dev-Alpha-10-browser-app-di...


Hope this helps. Smiley Happy

If it helped you, click like. Smiley Happy
New Contributor
Posts: 2
Registered: ‎08-26-2012
My Carrier: VODAFONE

Re: DevAlpha not updating on Desktop (Bundle 33) -

I tried to update in Windows 7 64 bits. The update showed the final message (without problems), but the blackberry 10 dev alpha hadn't changed the version. I tried several times with same final, until it kept stuck in Blackberry10 Dev Alpha logo (without animation).


I tried to wipe it, and the process finish with the download and installations of 2 packages, but, it kept stuck in the restart of mobile. I repeated the same process several times, same final...


Now, my Blackberry 10 dev alpha is stuck in logo... and i think that it doesn't charge, because if i disconnect from wall or pc, the mobile shut down.


If i restart the terminal with volume up + volume down + power = reboot and and stuck in logo...


Can someone help me? RIM gave me a cute brick...