Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Posts: 13
Registered: ‎10-08-2009
My Device: Not Specified

Eclipse Galileo and Plug-in 1.1 Question

I installed the JDE Plug-in version 1.1 upgrade today and as part of the install, it said it was required to upgrade my Eclipse installation to Galileo from Ganymede.  Once this was done, everything worked fine (i was able to view my code, run my apps in the simulator, and debug).  However, I notice that all compiles, builds, and runs are done in JDE v5.0 (which, I assume is tied to BlackBerry OS 5.0+).  I would like to do my coding and debugging in JDE 4.6.1, but I am having trouble determining how to set that configuration (with Galileo there's no more Blackberry Menu that shows the installed JDE...that I have seen).  I have reached the "Preferences (filter)" window, where it asks if I want to add a JRE.  JRE 5.0 is there currently, and when I try to add my .zip files for 4.6.1, it still asks for the JRE definition (an .ee file), which I cannot find.


Anyone know how I can go about doing this.  Will the 4.6 and 4.7 JDE Component Packs that I installed on Ganymede work on Galileo with the 1.1 version plug-in?  If so, how can I get these to work?


Thanks in advance!

New Contributor
Posts: 4
Registered: ‎05-31-2009
My Device: Bold 9000 & Playbook
My Carrier: Telenor Serbia

Re: Eclipse Galileo and Plug-in 1.1 Question

Same question here.


I have found a workaround. New plugin with hot-swap option is great, so I plan to use it for development and make final 4.6 (4.5,...) builds using old tools, as I used to.


After you have installed Eclipse + new 1.1.2 plugin, you can install 4.x simulators available on Blackberry site.


They show up next to default 5.0 devices in the Project Properties > Run/Debug Settings > Edit > Simulator > Device combo.


You can create, say, "4.6 run configuration" which starts old simulator. There is no hot-swap and it does properly raise exception in case some missing API is used (remember, you are developing using 5.0.0).


For the final 4.x builds, I copy the source files and use plain old JDE.


It is not perfect but I solves my problem: using new tools for faster development + support for old devices. There is need for additional attention, though. If you have find better solution, please share