Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Contributor
Posts: 7
Registered: ‎10-09-2012
My Device: n/a
My Carrier: n/a
Accepted Solution

JVM is incompatible

I run into this problem using multiple simulators for the BOLD, here is an example from the 9800 simulator:

 

Incompatible Application - BlackBerry 9800 Simulator

 

The JVM is incompatible with this simulator.

API mimatch (Apps: 155.25, OS: 149.3)

 

For security reasons, I will not be posting my JVM version. If anyone knows any possible solutions, would be great!

 

Thanks

BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JVM is incompatible

Where do you see that error?  What action triggers it?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Contributor
Posts: 7
Registered: ‎10-09-2012
My Device: n/a
My Carrier: n/a

Re: JVM is incompatible

Hi Mark,

 

I see the error as a pop up alert, immediately after selecting a simulator and pressing Go on the Launch Simulator application.

 

Thanks,

Ben

BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JVM is incompatible

Which BlackBerry SDK are you using?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Contributor
Posts: 7
Registered: ‎10-09-2012
My Device: n/a
My Carrier: n/a

Re: JVM is incompatible

Hi Mark,

 

Sorry for the late reply, I downloaded different phone simulators from http://us.blackberry.com/sites/developers/resources/simulators.html

 

I didn't download any software aside from these, which SDK would I need?

 

Thanks,

Ben

 

BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JVM is incompatible

This article explains compatibility between OS and SDK.

 

Appropriate version of the BlackBerry JDE and BlackBerry Java SDK

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Contributor
Posts: 7
Registered: ‎10-09-2012
My Device: n/a
My Carrier: n/a

Re: JVM is incompatible

Hi Mark,

 

I took a quick look and it seems to cover mainly developing. I'm testing a web application in the browser. The application doesn't target a specific model. Does this still apply?

 

Thanks,

Ben

BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JVM is incompatible

This applies to BlackBerry Java applications.

 

Are you building a WebWorks application using the WebWorks SDK or accessing your site purely in the browser?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Contributor
Posts: 7
Registered: ‎10-09-2012
My Device: n/a
My Carrier: n/a

Re: JVM is incompatible

Site, pureply in the browser.

 

Thanks,
Ben

Highlighted
BlackBerry Development Advisor
Posts: 15,885
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JVM is incompatible

Ok, and you see this error when launching the simulator from Ripple?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.