Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Highlighted
Developer
Posts: 74
Registered: ‎12-17-2009
My Device: Z30
My Carrier: O2
Accepted Solution

Just trying to install SDK is driving me mad

[ Edited ]

A few months ago, the QNX Momentics 10.2 I've downloaded was working fine until suddenly, the stimulator stopped working. I sorta gave up trying to develop my app. Recently I decided to pick it up again but I have so much trouble downloading the files (I know my internet is sometimes quite sloppy but...)

- Downloading the main installer file took me so many times I almost gave up. Kudos to my z30 which managed to download it by Reloading it again and again when it fails.

 

- However, I am trying to update the Simulator and API Levels etc. from the programme itself. Somehow the files are ALWAYS corrupted and the programme somehow don't realises this so it just keeps trying to run the corrupted zipfile, unsuccessfully of course. 

-- I know this because I can see the file stopped downloading at roughly 30-40MB.

 

Sorry for the rant. So my actual question is:

1. How can I manually download the SDK files to update? I have tried this other method (http://supportforums.blackberry.com/t5/Native-Development/Cascades-SDK-update-fails-An-error-occurre... ) but I could not find the requisite files in Step 7.

 

2. How to locate the half downloaded file from my system (where is its location) and maybe I can just try intalling it again? I have tried just clearing my Temp folders. But it still don't work.... still do not seem to want to download a fresh copy (from what I see?)

 

3. What else can I do?

 

Apologise for sounding so angsty. This is really getting into me as it seems to be such a simple yet unsolvable issue. I see posts dating back months ago and yet it doesnt seem to be resolved yet...

 

Please help thanks!

 

 

BTW This is the error message I get:

There was an error updating SDK. Press the Details button to review the error.
SDK Install or Update Operation operation failed: An error occurred while installing the items
An error occurred while installing the items
session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]bbndk.win32.simulator.10.2.0.1155 1.0.0, action=com.qnx.tools.ide.sdk.manager.core.actions.SdkManagerInstallAction).
error in opening zip file
error in opening zip file
An error occurred while installing the items
session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]bbndk.win32.simulator.10.2.0.1155 1.0.0, action=com.qnx.tools.ide.sdk.manager.core.actions.SdkManagerInstallAction).
error in opening zip file
error in opening zip file

 

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Just trying to install SDK is driving me mad

The update files are downloaded to <IDE_INSTALL_DIR>/p2/org.eclipse.equinox.p2.core/cache/.  Close the NDK, delete the files in that directory and try the update again.

 

If you have a different network you can download you could install the NDK and update there and then copy the installation directory from that computer to yours.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 74
Registered: ‎12-17-2009
My Device: Z30
My Carrier: O2

Re: Just trying to install SDK is driving me mad

Thank you.

Is it possible to manually download and install them instead?

I managed to install it on another computer/network. Can I just copy and paste the entire folder from that computer to the one I am having a problem with?
Regular Contributor
Posts: 74
Registered: ‎08-24-2013
My Device: Z10
My Carrier: Relaince

Re: Just trying to install SDK is driving me mad

hi , this is possible to manually install the native sdk on widows
Give a like.

1. please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?
" which solved it for you
Developer
Posts: 74
Registered: ‎12-17-2009
My Device: Z30
My Carrier: O2

Re: Just trying to install SDK is driving me mad

Thanks, may i ask how i may do that?