Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
Posts: 9
Registered: ‎11-27-2012
My Device: BlackBerry Z30
My Carrier: Virgin Mobile

Ripple Emulator fail to.... emulate.

Hi everyone, I've used Blackberrys a long time but I'm very new to developing and just learning html5,css, and javascript.

 

I downloaded the ripple emulator for chrome, I can get regular pages (like the google homepage) to appear in the emulator for playbook os2.0, but any of my local apps I cannot get to load, I always get the message

 

"Looks like what we have here is a failure to... emulate.

For some strange reason it looks like we are unable to load. This

could be a problem with your application, with ours, or that you may require more time to finish loading it."

 

Then I can hit "FIRE" to "pick up a shotgun and blow away all all of Ripple's settings in an attempt to purge out the bad stuff." or I can hit "Wait" 

 

I've tried hitting both and I just get the same page over and over.

 

When I am using the Ripple emulator on the google homepage, under "config" it says

 

- validation passed

- validation failed

- Node is missing, but not required

config.xml file could not be found in the application's root or is malformed XML.

 

Is it just showing this message because it's google's page and I can't actually get acces to their config.xml file? Or is it having trouble finding the xml files for my app?

 

I can't even get the hello world app to work on ripple.

 

I've downloaded the sdk and the ripple SDK path is set up to that file

Project root is set up to the specific folder of my app (index file is within the folder)

 

I've also tried closing and re-opening chrome, tried deleting and re downloading the ripple extension, and re starting my computer.

And in the ripple extension I have "Allow access to file URL's" checked.

 

I also saw a youtube video and he said to click your start menu, right click chrome, click properties, and in "target" add "--enable-extensions --allow-file-access-from-files" to the end, so i've done that.

 

Do I need to create a folder called "RippleSites" in C:\Users\username\ and put my whole app file in there?

 

Thanks in advance, I appreciate any help or suggestions you can give me, but try to keep it simple, and spell it out for me lol 

 

And if you have any questions just let me know.

 

 

8330-Playbook-9360-Z10-Q10-Z30
New Contributor
Posts: 9
Registered: ‎11-27-2012
My Device: BlackBerry Z30
My Carrier: Virgin Mobile

Re: Ripple Emulator fail to.... emulate.

and I'm running ripple v0.9.10 Beta, chrome v23.0.1271.95 m (most recent version)

 

also tried it on chrome canary and nothing changed

8330-Playbook-9360-Z10-Q10-Z30
Highlighted
Retired
Posts: 2
Registered: ‎06-13-2011
My Device: BlackBerry Z10
My Carrier: Bell

Re: Ripple Emulator fail to.... emulate.

Hi,

 

Thanks for the report. It looks to me like you're trying to access your site via the file:/// scheme and then enable Ripple on it. Looks like you've followed all of the right steps to get Ripple to work in the file:/// scheme, however, sometime you need to to close all instanances of Chrome and then open chrome fresh with the --allow-file-access-from-files flag.

 

This KB article will walk you through the exact steps: http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Solution-Ripple-Launch-is-Interr...

 

If you would prefer to run your app in the http:// scheme (which is what I would recommend). You can can do it as follows:

 

Start the Ripple Services (you can start them by clicking the Ripple icon and then clicking the "start services" button). Once you've done that and the services are running (you'll see a terminal window open up). You can visit http://localhost:9910 in Chrome. The first time you visit that URL the ripplesites folder will be created for you. I believe that is a bug... in that we really should be creating that folder at install time.

 

Once that's done, put your application folder into the ripplesites folder and then open it up in Ripple by going to:

 

http://localhost:9910/<your app folder name>/index.html

 

Hope this helps, but please don't hesitate to post back here if you run into any issues.

 

Best regards,

 

Dan.