Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Slow Simulator Deployments on Computers without a Network Connection

by BlackBerry Development Advisor on ‎12-12-2012 04:36 PM - edited on ‎12-12-2012 04:36 PM by Retired (3,605 Views)



Deploying to the BlackBerry® 10 Simulator takes many minutes to complete on computers without an active network connection that are running Windows®.




Windows can attempt to route the network connection initiated from a BlackBerry SDK to the VMWare® session running the BlackBerry 10 Simulator through the disconnected network adaptor(s).  The connection must time out to the disconnected adapter before Windows attempts to make the connection locally.




1.  Connect your computer to a network.




2. Perform the following steps to force local connections.



  1. At the top of your simulator, open the "Virtual Machine" drop down menu.
  2. Open the "Virtual Machine Settings" dialog box.
  3. Select /Network Adapter/ on the left.
  4. On the right, change the network connection from "NAT" to "Host-only".
  5. Click "Ok".
  6. Reboot your whole computer.

Note: When your computer comes back and you restart the simulator you will probably find that the IP address of the simulator is now different. You may need to change the target IP address in the BlackBerry SDK.

Users Online
Currently online: 25 members 1,952 guests
Please welcome our newest community members: