Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo
Accepted Solution

can no longer connect to Z10

[ Edited ]

Something strange happened to my Z10 and/or computer (2007 Mac Book Pro, OS X 10.8). Was doing some development this evening. I'd left Momentics open with SSH attached, but the app wasn't running.


I disconnected the USB cable connecting my Z10. Just a few minutes later, I reconnected it and could no longer connect from the development environment. The Z10 gave a message about trying to install Link on my computer. Link didn't seem to be connecting properly -- not listing my music, etc.


I reset both the phone and laptop. Same thing. Disconnected/reconnected USB cable to Z10. This time, reinstalled Link, since the phone was bugging me about installing it. Now Link seems to be able to see the phone (although music sync hung), and I can browse the onboard flash and SD card in Finder, but I still can't connect to the device from Momentics.


The specific error is:

Unable to connect.  Ensure USB cable or Wi-Fi is connected, IP address is correct, and development mode is enabled. 


I can't view the debug tokens either. Same error.


I have repeatedly verified that development mode is on. I tried changing the IP address. No luck.


Any ideas? I really need to get this working again (obviously).


EDIT: Actually... Maybe Link isn't connecting properly. It's telling me my phone has never been backed up, which is false. It's got the wifi icon by the name, and there's no explicit backup option.


EDIT 2: Randomly decided to turn off wifi. Got asked for my device password by Link finally and was able to start a backup. Unfortunately, I's been stuck at "preparing backup" for several minutes now. Doesn't seem to be getting anywhere at all. In the device menu in Link, only Backup, Restore and Remove are available -- the rest of the options are greyed out.

Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo

Re: can no longer connect to Z10

...and now it's working. I put it in airplane mode, unplugged it and plugged it back in. Link is finally able to do a backup, and Momentics can connect for file browsing, SSH, etc.


One clue to look for -- when it's not working, Finder shows the device mounted with an IP address that is not the development IP address. I don't know why it took so many disconnects/reconnects for it to finally use the development IP address.


I hope it had nothing to do with wifi off or airplane mode.