Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 2
Registered: ‎04-09-2013
My Device: non-blackberry user
My Carrier: non-blackberry user

not installing the bb10 simulator in ubuntu 12.04

Hi,

my os is ubuntu 12.04.i downloaded vmware 4.0.6 and install using following commands

sudo apt-get install build-essential linux-headers-`uname -r`

gksudo bash ./VMware-Player-4.0.6-1035888.i386.bundle

vmware is installed.like that i installed bb10 simulator after click on done button during installation it disappers.when i run the bb10 simulator in vmware it running certain commands but not opening the simulator.i cant't detect the simulator in eclipse.plese solve my problem.

i downloaded bb10 dv alphe simulator2.1.0 for ubuntu 12.04.

 

Developer
Posts: 38
Registered: ‎02-28-2012
My Device: Passport, Z10 & Playbook 64 GB

Re: not installing the bb10 simulator in ubuntu 12.04

I too am having some problems getting the simulator working with vmware. I get the following message:

 

[Error SUD:  cannot verify package id is invlaid, missing]

 

vmware.png

Passport 10.3.2.2474
Playbook 64 GB, Blackberry Z10
Highlighted
New Developer
Posts: 3
Registered: ‎04-07-2013
My Device: Z10
My Carrier: -

Re: not installing the bb10 simulator in ubuntu 12.04

I get a same error. Can anyone help? My OS is ubuntu 13.04.

I try to use virtual box, but it doesn't help.

New Developer
Posts: 3
Registered: ‎04-07-2013
My Device: Z10
My Carrier: -

Re: not installing the bb10 simulator in ubuntu 12.04

[ Edited ]

I solved the problem. You need to instal the proprietary driver for video card .

New Member
Posts: 1
Registered: ‎12-14-2013
My Device: Z10
My Carrier: UNICOM

Re: not installing the bb10 simulator in ubuntu 12.04

I have found a way to slove this.Before we countered this error,there were two steps to make some choice.first one shows "1,2,3,4" something else,maybe choose the partition.wo use default profile ,the one.second one notices us there are six choice ,default one is 1.when we choose it ,error happens.we can choose others .when I choose the six ,I can start the simulators.

 

maybe ,samrtphone resolution ratio is so higher than our notebook.we should chooose one accordance with our PC's.so,some one happens,others don't counter this problem.Because we have diffrent PCs.

New Developer
Posts: 12
Registered: ‎05-28-2014
My Device: Z10
My Carrier: Vodafone

Re: not installing the bb10 simulator in ubuntu 12.04

Yes, this worked for me too. I was already using a proprietary NVIDIA driver (on an ubuntu 14.04 ).

It seems only the 'safe mode' options are working.