Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Posts: 34
Registered: ‎05-15-2012
My Device: Playbook
My Carrier: Rogers

sdk not connecting to simulator

I'm brand new to the world of BB development.  I installed the BB10 native/cascades SDK, the VMWare player and the BB10 Alpha simulator.  I can get the simulator up and running in the virtual machine.  Then I start the IDE, and go to the Blackberry Deployment setup wizard.  It does not autodetect the simulator.  I enter the ip address from the simulator and the password, but the wizard keep saying "failed to set up simulator".

I have verified that i am in developer mode in the simulator.

I'm on a windows 7 machine.  I have turned off windows firewall and real-time AV.  Still doesn't work.

Any suggestions?

Posts: 34
Registered: ‎05-15-2012
My Device: Playbook
My Carrier: Rogers

Re: sdk not connecting to simulator

hmmm, this is getting very frustrating.  I can't even ping the simulator, so the problem seems to be between my computer and VMWare.

I tried bridged mode and host-only mode, still no good.

In my windows network settings, i see two VMWare adapters under "public network".  One is called VMNet1 and the other is called VMNet8. 

- Under properties, both VMNet1 and VMNet8 say "No network connectivity" for network connection,

- both say Media State: Enabled

- both have a speed of 100.0Mbs. 

- both show in increasing number of packets sent, and 0 packets recieved.

- I went into options and checked "VMWare Bridge Protocol" in the list of things. 

-  The IP addresses are both different from my simulator IP address.

VMNet1 (ping works)

VMNet8 (ping works)

BB10 simulator IP: (ping gets transmit failed: general failure).


Does any of this point to what my problem might be?  I'm eager to get started and stuck at the gates!


New Developer
Posts: 6
Registered: ‎05-29-2010
My Device: bold9000
My Carrier: cm

Re: sdk not connecting to simulator

hi,have you solved this problem?
I have the same problem with you .
Posts: 209
Registered: ‎05-08-2012
My Device: PlayBook 64 Gb and Z10 LE
My Carrier: Vodafone

Re: sdk not connecting to simulator

U used the correct IP address?






If U like my post click on LIKE Smiley Wink
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: sdk not connecting to simulator

Have you tried browsing from inside the VMware.  ie: can you use the playbook browser to visit sites from within the VM player?  This would tell you if there's even a connection between the player and the outside world.

If it helped you, click like. Smiley Happy
Posts: 18
Registered: ‎07-24-2012
My Device: Bold 9650
My Carrier: Unicom

Re: sdk not connecting to simulator

Please try these steps with SDK:


1) Make sure you can ping the IP( such as of simulator from cmd.exe

2) Select "Windows"-> "Preferences" -> "Network Connections"

3) Set the "Active Provider" to "Native"

4) Connect again.

New Member
Posts: 1
Registered: ‎08-22-2012
My Device: 9360
My Carrier: telecom

Re: sdk not connecting to simulator

So Cool! I logon the forum for this issue, and these steps fix my problem, which blocks my study.

New Developer
Posts: 11
Registered: ‎08-11-2012
My Device: BB 10 DevAlpha
My Carrier: ChinaMobile

Re: sdk not connecting to simulator

always first choice to find the answer