Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 4
Registered: ‎11-05-2009
My Device: Not Specified

Anchor Links in HTML Email

[ Edited ]

Hello,

 

I'm currently working on an HTML email to be used as a template and viewed on a range of BlackBerry's. The basic concept is a table of contents at the top that points down to article content lower in the email, and then "back to top" links to navigate back up to the top of the email.

 

The anchor links work just fine to jump a user down to the articles, but the "back to top" anchor links do not. Any ideas?

 

I've checked and validated all of the code... It's simple <a name="thisistheanchor"></a> and <a href="#thisistheanchor">link</a> stuff.

 

The "back to top" anchors work fine when viewed using Outlook or on a web page, just not on a BlackBerry (although as I said, the anchors to jump down to text content do work on BB).

 

Thanks for any suggestions... OS 4.6

 

======

Edit:

 

The <a name="thetop"></a> anchor appears to not work when placed directly after the <body> tag, or within the first <tr><td> area of the table. In the second row of the table (the second <tr><td> area) it works just fine. Quite strange...

 

It could be that the anchor isn't working within the first row because it has a colspan="2" setting? Or something to do with the conversion from straight HTML web page to HTML email?