Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 5
Registered: ‎11-25-2009
My Device: Not Specified

App Icon is showing on desktop but after click app is not starting

Hi..

I am new to BB dev.I have made a web app for blackberry.

After finishing the app i installed it on device, few days it worked on device very fine,now the app is not starting.

Any one can suggest any  solution ??

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: App Icon is showing on desktop but after click app is not starting

Hi There,

 

By "web app" do you mean a BlackBerry Widget?  What is your application doing on first load?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 5
Registered: ‎11-25-2009
My Device: Not Specified

Re: App Icon is showing on desktop but after click app is not starting

Hii. thanks for reply.. this app is showing some off-line pages in BB browser.On clicking on icon on desktop its showing the index page of the app. In development i have used jde 4.5.

 

plz solve this problem...

thanks

 

 

 

Windows XP -64 bits

New Developer
Posts: 5
Registered: ‎11-25-2009
My Device: Not Specified

Re: App Icon is showing on desktop but after click app is not starting

Hi..

 

Hi..

I am new to BB dev.I have made a web app for blackberry.which displays some offline web pages.

The size of the .cod file 4.38Mb because i have to display 812 web pages.

After finishing the app i installed it on device, few days it worked fine on device very ,but after that  the app is not starting.But its still working on simulator.I have tested the app on BB simulator 4.xxx and device is 8100.

 

 

Here is the main function of my app

 

 

public static void main(String[] args) {
        try {
            HomeScreen.setRolloverIcon(
                    Bitmap.getBitmapResource("www/ftg2.png"), 0);
            HomeScreen.updateIcon(Bitmap.getBitmapResource("www/ftg1.png"), 0);
        } catch (Exception e) {
          

        }
        WebApp bridge = args.length > 0 ? new WebApp(args[0])
                : new WebApp();
        bridge.enterEventDispatcher();
    }

Any one can suggest any  solution ??

 

I have no idea how its working for 1 st few days .

 

 

 

I have used Windows XP -64 bits