Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Contributor
Posts: 6
Registered: ‎10-09-2013
My Device: Z10
My Carrier: Verison
Accepted Solution

App world denial because of icon and app stuck on first page

I've recently submitted my app for approval however I've recieved the same feedback problems twice now:

 

- After installing your application on BlackBerry Z10,Q10,Z30, we notice the application icon is / mark questions. If you are using our Eclipse plug-in, please check your BlackBerry_App_Descriptor.xml file and ensure you are specifying your custom application icon correctly 
- When tap your app, the app stuck on first page. Please make sure your app work properly. 

 

I've included a custom icon and specificed it in the config file with the <icon src="path_name" />.

 

I've also run the app on my dev-alpha device with no problems. The screenshot I recieved the first time from BB support showed no Action Bar coming up to navigate away from the splash screen; however, when I run the app on my dev-alpha device I am able to see the action-bar and navigate to my three screens.

 

Has anybody else run into this problem?

 

All my code is available to inspect at github

 

Thank you in advance for the help.

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: App world denial because of icon and app stuck on first page

Hi there,

Which OS version are you running on your device?

The action bar will likely be due to an out-dated version of bbUI.js being used. Currently you are using:
https://github.com/InnovateorDieOnline/BOTE/blob/master/index.html#L11

Which is: bbUI VERSION: 0.9.6.15

Whereas the most recent:
https://github.com/blackberry/bbUI.js/blob/master/pkg/bb10/bbui-min.js

Is actually: bbUI for BB10 VERSION: 0.9.6.889


There were a number of updates to BBUI that were needed in order to support later versions of 10.1 and 10.2. Likely an update to your BBUI library is required.


As for the application icon, I am not exactly sure. If you are willing to send me your BAR file (eoros@blackberry.com), I can verify that the config.xml / BAR Descriptor are configured properly.

Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Contributor
Posts: 6
Registered: ‎10-09-2013
My Device: Z10
My Carrier: Verison

Re: App world denial because of icon and app stuck on first page

Erik,

 

I very much appreciate your help. Thank you for directing me to the new bbui.js files.

 

You are correct my dev-device has an earlier OS 10.0.9.2372 but it seems that the update servers are down for now.

 

I have just sent you an email that has the attached .bar and config file.

 

I haven't be able to compile a new bar file yet because it appears the websigning server is down.

 

" Error: Server returned HTTP response code: 502 for URL: http://www.rim.net/Websigner/servlet/RDK-Waterloo" (from my Gap for HTML)

 

I'll try again later tonight if the servers are back up.

 

Thank you again.

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: App world denial because of icon and app stuck on first page

For the OS version, I would recommend updating via Autoloader here to get to the latest 10.2 beta. 10.2 is what the BlackBerry World teams will be testing against so it's best to ensure things are working / looking right there.
https://developer.blackberry.com/blackberry10devalphas/update/

I've received the signed BAR file and will look into the icon issue today.

Cheers

Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Contributor
Posts: 6
Registered: ‎10-09-2013
My Device: Z10
My Carrier: Verison

Re: App world denial because of icon and app stuck on first page

Erik,

 

Thank you for looking at both my problems.

 

I've successfully installed the BB10.2 update on the my dev device and now just working through the problem of uploading debug tokens again to the device.

 

The Gap for html5 dialog box  keeps saying the connection to the IP address times out. I'm going to try using the command line to install the tokens and launch the app if I can't get it working in the next hour.

 

Thanks again for all your help.

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: App world denial because of icon and app stuck on first page

Sure thing! Just to double check, have you enabled Developer Mode in your device Settings?


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Contributor
Posts: 6
Registered: ‎10-09-2013
My Device: Z10
My Carrier: Verison

Re: App world denial because of icon and app stuck on first page

Yep. Thanks for checking though. 

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: App world denial because of icon and app stuck on first page

I have seen devices get into a "weird" USB state. Changing the USB port you are plugged into, using a WiFi IP address, or restarting the device/PC are all potential options. 


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.