Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 6
Registered: ‎06-23-2012
My Device: bold
My Carrier: docomo

BB Bold web container problem

Hello everyone,

 

We are developing a hybrid application in blackberry.The target device is bold.But we are facing some weird problem since last 1 month.The problem is on each and every page we have a service call to native function using window.external.notify method in javascript.The problem is when we are keeping device idle for 20 sec and then go back to previous page then the page is not loading and when we checked the issue it is stopping at window.external.notify method and when we refresh the page then the page is working fine.

 

We are not able to understand the exact issue.When we deployed the same in torch it is working fine even if we keep it idle for 20sec or more.I want to know whether it is an OS issue or device issue?????

 

If we are not able to find the exact issue it will be a big setback for us as it is a big project.So please if anyone has faced such issues in past please do share with us.

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: BB Bold web container problem

Sorry I'm not sure what the issue is.  Can you provide more details about the Bold device you are observing the problem on - what model # and version of the OS do you have running?

 

I don't believe the "external" object is fully supported.  It could be an issue with some feature that is partially supported?

https://developer.blackberry.com/html5/documentation/ww_webrefs/Window_Objects_1180986_11.html

 

What are you trying to do when you call into a native function?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Highlighted
New Contributor
Posts: 6
Registered: ‎06-23-2012
My Device: bold
My Carrier: docomo

Re: BB Bold web container problem

Hello Adam,

 

I am working on bold 9900 os version 7.0.I just want to get the device language so that i can show my webpages accordingly.It is working fine in flow but if i keep device idle for 20 sec i need to refresh it to call the native call.