Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 20
Registered: ‎06-06-2013
My Device: BlackBerry Curve 9320
My Carrier: Vodacom
Accepted Solution

BB10 - unable to launch to the simulator

I'm running Windows 7 and launching from a command script 

 

C:\Windows\system32>cd "C:\Program Files\Research in Motion\BlackBerry 10 WebWor
ks SDK 1.0.4.11\dependencies\tools\bin\blackberry-deploy" -installApp -device <IP address> -package "C:\Users\<UN>\RippleSites\bb10ww\ui_output\simulator\ui.bar"
The filename, directory name, or volume label syntax is incorrect.

Thanks upfront

Marc

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: BB10 - unable to launch to the simulator

This looks like the problem to me:

 

C:\Users\<UN>\RippleSites\bb10ww\ui_output\simulator\ui.bar

 

Can you confirm the correct path?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Contributor
Posts: 20
Registered: ‎06-06-2013
My Device: BlackBerry Curve 9320
My Carrier: Vodacom

Re: BB10 - unable to launch to the simulator

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd "C:\Program Files\Research In Motion\Blackberry 10 WebWor
ks SDK 1.0.4.11"

C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11>bbwp "C:
\Users\M\RippleSites\bb10ww\MyTravelLogFinal.zip" -d -o "C:\bb10archives"

C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11>"C:\Prog
ram Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11\third_party\nod
e\windows\node.exe" "C:\Program Files\Research In Motion\BlackBerry 10 WebWorks
SDK 1.0.4.11\lib\bbwp.js" "C:\Users\M\RippleSites\bb10ww\MyTravelLogFinal.zi
p" -d -o "C:\bb10archives"
[BUILD] Populating application source
[BUILD] Parsing config.xml
[WARN] Build ID set in config.xml [version], but no signing password was prov
ided [-g]. Bar will be unsigned
[BUILD] Generating output files
[WARN] Failed to find debug token
[INFO] Info: Package created: C:\bb10archives\simulator\MyTravelLogFinal.bar
[WARN] Failed to find debug token
[INFO] Info: Package created: C:\bb10archives\device\MyTravelLogFinal.bar
[BUILD] BAR packaging complete

C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11>cd depen
dencies\tools\bin

C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11\dependen
cies\tools\bin>blackberry-deploy -installApp -launchApp -package "C:\bb10archive
s\simulator\MyTravelLogFinal.bar" -device 192.168.153.128
Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: File size: 2872327
Info: Installing MyTravelLogMax.testDev_ravelLogMax3c18cf26...
Info: Processing 2872327 bytes

C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.4.11\dependen
cies\tools\bin>