Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
Developer
Posts: 195
Registered: ‎05-09-2012
My Device: Playbook, Z10 LE

BBM integration testing on Dev Alpha (No contacts, panel does not show, etc...)

I am testing my app with Dev Alpha B and Dev Alpha C. I have used the samples in GitHub as a base (and I have tested the samples too).

On both simulators when when "Invite to Download", the list with the contacts to choose from is empty and no contacts can be chosen. On the Dev Alpha B simulator sometimes the panel slides up a little bit, then flickers and disappears.

 

The other function I use is to send a message from my app to BBM (via invoke). This works as I expect it should work. I can select a contact and send the message.

 

I have no real devices to test on. Is "Invite to Download" broken on the Dev Alphas? If I submit the app for approval, will it be denied??

BlackBerry Development Advisor
Posts: 15,752
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: BBM integration testing on Dev Alpha (No contacts, panel does not show, etc...)

This looks like an issue with the simulator.  I'm going to report it to our development team.  But don't worry about this causing issues for your submission.  It should work fine on a real device.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 195
Registered: ‎05-09-2012
My Device: Playbook, Z10 LE

Re: BBM integration testing on Dev Alpha (No contacts, panel does not show, etc...)

[ Edited ]

Thanks... It probably is not an issue because the app is already approved and in available in AppWorld.

 

The simulator is glitchy though...  What I have reported as a bug that no contacts can be selected that might be actualy a feature and not a bug. I just dont know what to expect but the bbm dialog sometimes fails to appear and the simulagor and even. Vmware need to be restarted.