Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 3
Registered: ‎02-11-2013
My Device: Curve 3
My Carrier: MTN

BlackBerry Push Service : Error 404

Can someone help, I am getting error 404 when post to Base Url.

New Developer
Posts: 17
Registered: ‎05-20-2010
My Device: Passport
My Carrier: AT&T

Re: BlackBerry Push Service : Error 404

bolajiniy

 

That sounds like your having an internal connection issue. Probably no internet connection.

 

Are you getting back a success status when calling  blackberry.push.PushService.create({options},successCallback,failCallback,

simChangeCallback,pushTransportReadyCallback)

 

from the successCallback?

 

if not you might have to check how your creating the push channel

 

https://developer.blackberry.com/html5/apis/blackberry.push.pushservice.html

 

 

 

Creator of Todomate for BlackBerry 10 | follow me on twitter @lchampagnie
Highlighted
New Contributor
Posts: 3
Registered: ‎02-11-2013
My Device: Curve 3
My Carrier: MTN

Re: BlackBerry Push Service : Error 404

Thanks for your response, Error 404 means file not found. I dont have internet issue.

 

After sign up for push service I was sent a mail with my account details.

 

I have not been able to use the account, I was able to sign to the control panel and it looks good.

However, the client and server URLs given are not working, getting error 404. I have made different changes to the urls:

For server I have tried : https://cp3417.pushapi.eval.blackberry.com/ and https://3417.pushapi.eval.blackberry.com/ but all in vain. My posts were not successful. But when I used the same code with https://pushapi.eval.blackberry.com/mss/PD_pushRequest it works to an extent, but getting 'No Active Subscribers for the Push Service'. I changed my client App to listen using http://pushapi.eval.blackberry.com/mss/PD_pushRequest pushRequest but same error.

Below are the client url variations I've tried:
http://pushapi.eval.blackberry.com/mss/pushRequest
http://cp3417.pushapi.eval.blackberry.com/
http://3417.pushapi.eval.blackberry.com/

I have check some articles on this, some say the server is down which I am not sure.