Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 12
Registered: ‎12-17-2009
My Device: Not Specified

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

Cannot complete the install because one or more required items could not be found.
  Software being installed: BlackBerry Web Plug-in 2.0.0.200910291414-12 (net.rim.browser.tools.feature.feature.group 2.0.0.200910291414-12)
  Missing requirement: BlackBerry Web Plug-in 2.0.0.200910291414-12 (net.rim.browser.tools.feature.feature.group 2.0.0.200910291414-12) requires 'org.eclipse.core.runtime [3.4.0,3.5.0)' but it could not be found

 

 

Eclipse i have installed is galleo 3.5 version. platmorm is windows Xp 32bit

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

For the BlackBerry Web Plug-in Beta it requires version 3.4.x of the Eclipse environment.

 

If you want to leave your 3.5 environment as is, and still get the web plug-in.  I would suggest downloading the full installer of the web plug-in beta.  It includes a copy of Eclipse 3.4 with our plug-in installed into it.  You can simply install this into a different directory than your 3.5 version.

 

The final release version of the web plug-in when it comes out of Beta will be targeted at Eclipse 3.5

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 2
Registered: ‎01-07-2010
My Device: Tour
My Carrier: Verizon

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

I installed the beta becuase I was trying the 1.2 version and it would not launch the simulator when entering debugging. I am using VS 2008 fully patch and running Vista 32-bit running with full admin permission. Now I have installed this version the simulator will launch, which is fantastic. Now I cannot figure out how to change the simulator. I have gone to Tools->Options->Blackberry->General. I have Default Blackberry Widget Simulators 9500 (Version 5.0.0.307) for both ASP.NET and Wdget. For the ASP.NET SImulator I would like to change it to one of the other simulators I have installed. The drop down list only shows me the default, but whe I click to see a list of installed simulators. I can see my 8830 and 9630. How do I get to use these?

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

Hi there,

 

Currently the BlackBerry Tour 9630 isn't included as one of the platforms that can be debugged.  You must have a simulator that has at least 4.6 or higher on it to be able to be used for debugging.  The BlackBerry Tour with OS 4.7.1 is currently the one exception to this rule.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 2
Registered: ‎01-07-2010
My Device: Tour
My Carrier: Verizon

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

I loaded up two more Simulators the 900(v4.6.0.266) and the 8900 (v4.6.1.94) only the 9000 can be choosen from the drop down list. So there obviously is a problem somewhere.

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

Sorry about that.. to be more specific, our product web page states the following as requirements for simulators

 

Note: The minimum OS versions to target for the BlackBerry Plug-in for Microsoft Visual Studio are v4.6.0.212, v4.6.1.132 and v4.7.0.80.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 9
Registered: ‎01-09-2010
My Device: BlackBerry Curve 8530

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

[ Edited ]

Are there specific steps to follow when updating the BlackBerry Eclipse Plugins?  I have a prior version of this web plugin and wanted to make sure that I don't hose my entire setup.

 

Any info at all would be greatly appreciated.  Thanks!

Contributor
Posts: 25
Registered: ‎03-29-2011
My Device: 9000 BOLD
My Carrier: vodafone

Re: BlackBerry Web Plug-in 2.0 beta 1 released!

hii

 

i am new in this BB.

please tell

what's this widget means and this web plug-in 2.0 beta 1 is for what?

with which this plug-in is related???

 

reet