Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 3
Registered: ‎12-18-2009
My Device: Not Specified

Blackberry dropdown / postback problem

[ Edited ]

Hello,

 

We implemented a .net 3.5 Web application.

When using the Blackberry native browser the dropdowns were not working at all (the events were not fired). The buttons events worked ok, but there was no postaback when changing the dropdown option.

 

To solve this issue we implemented a browser configuration file (.browser) with the blackberry specifications and added it to the application.

But it is not working all the time.

Usually on the first load the dropdowns aren’t working, but after a refresh everything is working fine.

 

As we know, the ‘.browser’ file is loaded by ASP.NET when the application is started.  In our case it is loaded later (after using the browser refresh button).

Also, after using the magnifier the dropdowns stop working (????).

 

We tried to host the application on different servers and the problem persists on all of them. So we think that’s a blackberry native browser specific behavior.

Is there a workaround? Is that a known issue?

Do you have any suggestions on how to solve this problem?

 

Note:  the application is available at www.mobileobs.com, but you have to be logged in to reproduce the problem. i'd like to not post credentials here, please contact me on email and i'll provide you test credentials.

Used device: 8350 Curve.

 

I’m looking forward for your answer.

 

Thank you in advance.

 

Ina

Highlighted
New Developer
Posts: 3
Registered: ‎12-18-2009
My Device: Not Specified

Re: Blackberry dropdown / postback problem

anyone? Smiley Sad