Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 178
Registered: ‎11-19-2008
My Device: Not Specified

Cannot get the hello world project to work

After giving up on trying to run the VMWare emulator with no virtualization support, I though using Ripple to test the GUI and then testing on device would be an alternative.

First of all, I'm developing in a Windows XP machine. I'm able to run even the heaviest Android and BB7 emulators.

I've created step by step the hello world project, the index.html page being reachable in localhost by means of a Tomcat server.

I've successfully installed the last available Ripple extension, downloaded from the Blackberry site. I've configured the SDK path, project root, archive name and output folder in the settings dialog.

The first and most important problem I've now is that the hello world doesn't work. The blackberry UUID is not showing in the emulator. All I can see is the "Hello World" text.

Given that my VMWare emulator is unusable (my CPU has no Intel VT extensions, so it is extremely slow), and the ripple emulator is not showing the UUID for whatever unknown reason, the only option left for me is to package and deploy on my alpha device. So I click in the package button and I get this error:

Oh Snap! Build request failded with message: error
This could be due to the Build and Deploy services not running or not being installed

So I click the "start services" button, and I get a new different error:

Windows can't find the file 'C:\Documents and Settings\<my user name>\Local Settings\Application Data\Chromium\User Data\Default\cnijnnaimeaacneklcdncafbnkeicckh\0.9.13_0\plugins/.../services/bin/ripple-services'.

The odd thing in this path is how it is mixing slash and back slash in the same path. And of course the file does not exist (as such file path is illegal in a windows machine). However, the file is in this path:

C:\Documents and Settings\<my user name>\Local Settings\Application Data\Chromium\User Data\Default\Extensions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.13_0\services\bin

After this, the build tab shows the message "The build and deploy services are currently running at http://127.0.0.1:9910". Obviously no file was created in the output folder.


My questions:
-How is such a simple static hello world web page not working and why.
-How can I fix the build error other than changing to a Windows Vista or Windows 7 machine (apparently this works out of the box there). Other devs with WXP report they have the same problem so it's not just my machine.
-How is it possible anyone at RIM though this ripple thing is ready for release.

 

Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Cannot get the hello world project to work

Hey Darkberry,

 

Sorry you ran into so many issues just starting out -- a few things: Do you think you are running into any permissions error on your machine where the output folder is failing to write? Also have you tried to build the .bar file using just command line without any GUI help? Thanks!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Developer
Posts: 178
Registered: ‎11-19-2008
My Device: Not Specified

Re: Cannot get the hello world project to work

No, there's no permissions error, in fact the error happens before the packaging stage. There's a problem starting the services, probably because Ripple is trying to access the wrong path.

 

As for building the bar file using commands, yes that might be possible, but it is not as convenient.

New Contributor
Posts: 3
Registered: ‎02-13-2013
My Device: Curve
My Carrier: Can't tell you

Re: Cannot get the hello world project to work

I had the same problem yesterday.

 

You won't believe what the problem is....there is EULA that you must accept in order for the Ripple addon to work.

 

 

Credit:

https://github.com/blackberry/Ripple-UI/issues/699

 

Developer
Posts: 178
Registered: ‎11-19-2008
My Device: Not Specified

Re: Cannot get the hello world project to work

I don't thing this is what happens in my case. I can see the button and as far as I remember I accepted the EULA the first time I tried to use it.

Developer
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C
My Carrier: 3, Orange, Vodafone

Re: Cannot get the hello world project to work

I'm wondering if its the spaces?

 

M$ have a very funny (not) habit of putting spaces in filenames so it's perfectly possible that XP is going wrong because of this

 

Something I'd do in this situation would be to remove all dev tools then re-install them all but choosing your own paths - e.g. BBSDK (there's an opotion to do this)

 

This removes one possible issue from the myriad problems you could have

 

Hey - it don't work - you can't break it more Smiley Happy

 

Be careful if you try this out though as getting back to the current state will be impossible




Click the like button if you find my posts useful!