Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Contributor
Posts: 9
Registered: ‎10-14-2011
My Device: Bold 9700
My Carrier: T-Mobile

Cannot sign application - failed to find signing keys

Today I updated to the new SDK and I'm having issues with signing the applications. I've downloaded three sets of keys that I installed under preferences and have included all three csi's. I have the sigtool.csk and sigtool.db in the following folder:




Any thoughts? I should also note that this app is using phonegap, so I followed instructions here as well.



Thanks for any ideas!



Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Cannot sign application - failed to find signing keys

When you say that you have updated to the new SDK, which version have you updated to?  


Also, you show a path for the Eclipse plug-in directory.  The Eclipse plug-in is not compatible with the latest SDK so I'm guessing you installed the latest SDK somewhere else on your system than the file path you posted.


Some more clarification would help us get to the root of the issue.



Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Contributor
Posts: 9
Registered: ‎10-14-2011
My Device: Bold 9700
My Carrier: T-Mobile

Re: Cannot sign application - failed to find signing keys

Thanks! Knowing that the SDK is not supported by the plug-in helps. The SDK is in the folder for c:\development\bbwp. I was able to run the build from cmd, per the instructions on this page (https://bdsc.webapps.blackberry.com/html5/download/sdk), but I wasn't prompted for a password here either and it failed on the device. Should I be using a different command?

New Contributor
Posts: 9
Registered: ‎10-14-2011
My Device: Bold 9700
My Carrier: T-Mobile

Re: Cannot sign application - failed to find signing keys

I figured it out. Because I had added the keys under the incompatible Eclipse plugin, the sigtool.csk, sigtool.db and sigtool.set were not in the bin folder for the SDK. I added those and ran the build via command line and everything worked as expected. It also worked from Eclipse after it was added to the sdk bin. 

New Contributor
Posts: 3
Registered: ‎08-29-2012
My Device: Blackberry Dev Alpha
My Carrier: Airtel

Re: Cannot sign application - failed to find signing keys

Same Issue has come up for me

Before Updating SDK

1. Make Sure the JAVA_HOME in Environment is pointing to right directory

2. AdobeAIR SDK is installed.

3. Backup the Signing keys


After updating SDK

1.Copy the backed p12, csk and db certificates to folders

2.If you applied and got new keys. Remove the old certificates from these directories before installing them.

3. Author.p12 should be Changed to sigtool.p12 everywhere


That should sign the application


Since I have spent  considerable time today doing the same. I have given the way I got it.


There is one Blackberry Graphical Aid, which seems to be new. But it does not work for me still