Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Developer
Posts: 14
Registered: ‎01-07-2009
My Device: Not Specified

Configuring the BlackBerry WebWorks Plug-in for Eclipse

Hello,

 

Please help! I'm just want to get an initial Hello World app up and running using Webworks in Eclipse.

 

I'm struggling to get WebWorks up and running while using Eclipse, and following the

"BlackBerry WebWorks Plug-in for Eclipse

Installation and Configuration Guide" at
I'm on page 4, titled "Configuring the BlackBerry WebWorks Plug-in for Eclipse". Here are the steps:
Create a server configuration
1. In Eclipse®, on the Window menu, click Show View > Other.
2. Expand Server.
3. Click Servers.
4. Click OK.
5. In the Servers view, right-click and click New > Server.
6. Expand Apache and click Tomcat v6.0 Server.
7. Click Next.
8. Browse to the Apache Tomcat™ installation directory and click OK.
9. Click Finish.
10. Right-click the new server configuration. Click Add and Remove Projects.
11. Add existing BlackBerry® web application projects to the server configuration.
12. Click Finish.
13. To start the new server, click the green button in the upper right corner of the Servers view.
In step 8, I added a step to install the Tomcat by clicking on the "Download and Install..." button. I chose an install folder then set that folder as the "Tomcat installation directory".
I get to step 10 where the only option I see when I right-click is "Add and Remove...". When I select this option I see the following error message:
"There are no resources that can be added or removed from the server."
Any ideas as to what I'm doing wrong here?
I really just want to get an initial Hello World app up and running.
Any help is greatly appreciated!
-Jason