Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 27
Registered: ‎05-12-2011
My Device: Playbook 2.0, Dev Alpha A
My Carrier: Waiting for BB 10
Accepted Solution

Dev Alpha app builder bug?

Who should I contact if this proves to be a valid bug?

 

This particular app has been accepted on the Playbook and I'm now submitting it to Dev Alpha.

I'm calling a web server to store an email address that 'strangely' contains an '@'.  You know, like abc@gmail.com

Up pops a Javascript alert... something like 'access to xxxx.php is not allowed'.  That's after I've already successfully accessed the server.

 

Now if I remove the '@' the butchered email address is successfully, but uselessly, stored on the server.

 

Exactly the same code works fine with an '@' on a PC browser and the PlayBook browser and compiler!

 

BTW I'm quite paranoid, I refuse to use jquery, bbui.js, or even webworks.js.  Maybe in a year or so.

 

Who should I contact if this proves to be a valid bug?

 

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Dev Alpha app builder bug?

Hi there,

 

To submit bugs with WebWorks applications, your best bet would be Github:

https://github.com/blackberry/BB10-WebWorks-Framework

 

That being said, the @ symbol seems suspiciously similar to a special character. If it's already been working on the previous platforms, perhaps it truly is a bug, however it may also be worth encoding the data on the client-side, then decoding the data on the server-side. A good example of this is here:

http://www.w3schools.com/html/html_urlencode.asp


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Highlighted
Developer
Posts: 27
Registered: ‎05-12-2011
My Device: Playbook 2.0, Dev Alpha A
My Carrier: Waiting for BB 10

Re: Dev Alpha app builder bug?

Yes, encoding/decoding the '@' would be the way to go for now, at least so I could submit the product quickly.

Thanks Erik!