Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 482
Registered: ‎10-24-2008
My Device: 9300
My Carrier: AT&T

E4X Supported in the 5.0 browser?

I looked up the browser support document (http://docs.blackberry.com/en/developers/deliverables/11844/BB_Browser_content_support_by_version_43...) and saw that OS 5 had partial support for ECMAscript 1.6.

 

Does that support include E4X?

_________________________________________
www.jasonmace.com/blackberry
Highlighted
Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: E4X Supported in the 5.0 browser?

Hello jmace, At this point in time the BlackBerry Browser does not support E4X. Please note that partial support for JavaScript 1.6 is also included in version 4.7.1 of the handheld software (introduced on the BlackBerry Tour 9630). Best regards, Adam
Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.