Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

New Developer
Posts: 8
Registered: ‎08-12-2009
My Device: Blackberry Bold
Accepted Solution

Eclipse Web Plug-in build and run problem



I downloaded the BlackBerry Web Plug-in for Eclipse v2.0 Beta 1 with Eclipse 3.4


When I choose Run-As -> BlackBerry Widget, the build and run process never finishes. I get a message in the console saying



BUILDING BasicWidget

cmd.exe /c bbwp D:\Projects\eclipseworkspace\BasicWidget\build\BasicWidget.zip /o D:/Projects/eclipseworkspace/BasicWidget/build


When I click on the progress tab, i can see the status as "Building Widget Projects" keeps goin on and on.


I checked in the task manager, i see cmd.exe and bbwp.exe still alive and never quits, can any suggest me what the problem would be ?


Tried to run the D:\eclipse\plugins\net.rim.browser.tools.wcpc_1.0.0.200910291414-35\wcpc\bbwp.exe manually, I get "Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file"


java version "1.6.0_11"
Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
Java HotSpot(TM) Client VM (build 11.0-b16, mixed mode)

Windows XP SP3 32bit








New Developer
Posts: 8
Registered: ‎08-12-2009
My Device: Blackberry Bold

Re: Eclipse Web Plug-in build and run problem

I guess the bbwp.exe which calls the bbwp.jar was compiled in a latter version of java.


java 1.6.0 update 11 doesnot work.


i tried java 1.6.0 update 17, everything is fine.


RIM just needs to update their requirements http://na.blackberry.com/eng/developers/devbetasoftware/eclipseplugin.jsp to from ( SUN JDK 1.6 or higher ) to ( SUN JDK 1.6 update XX or higher )

Posts: 84
Registered: ‎06-26-2008
My Device: Not Specified

Re: Eclipse Web Plug-in build and run problem

I had similar problem


I was getting

BUILDING widget cmd.exe /c bbwp D:\Proyectos\eclipse\workspacebb\widget\build\widget.zip /o D:\Proyectos\eclipse\workspacebb\widget\build Error occurred during initialization of VM java/lang/NoClassDefFoundError: java/lang/Object


I resolve it upgrading from jdk6_16 to jdk6_19