Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Contributor
Posts: 3
Registered: ‎07-22-2012
My Device: playbook
My Carrier: ATT

Erro with Webworks Archive when packaging

Newbee to Webworks, I keep having this error message when trying to package my app into a .bar file.


[INFO] Parsing command line options
[INFO] Parsing bbwp.properties
[INFO] Validating WebWorks archive
Exception in thread "main" java.lang.NullPointerException
at java.util.PropertyResourceBundle.handleGetObject(Unknown Sour
at java.util.ResourceBundle.getObject(Unknown Source)
at java.util.ResourceBundle.getString(Unknown Source)
at net.rim.tumbler.log.Logger.logMessage(Logger.java:38)
at net.rim.tumbler.WidgetPackager.go(WidgetPackager.java:213)
at net.rim.tumbler.WidgetPackager.main(WidgetPackager.java:77)


Also, this is my second time trying to packing a applicaiton. I used a new set of keysigning files. The .p12, .csk,.db file is generated correctly. I have no idea what problem could lead to the error message during validating WebWorks archive.


Posts: 64
Registered: ‎06-04-2012
My Device: Blackberry Z10
My Carrier: Bell

Re: Erro with Webworks Archive when packaging

It seems like there may be a problem with the zip file. What commands are you using? Have you also tried packaging it using the Ripple emulator?

- Did this post help solve the issue? Click on "Accept as Solution"
- Was the content of this post helpful? Please give it a "Thumbs Up"

Posts: 236
Registered: ‎07-27-2012
My Device: BlaclBerry PlayBook 16gb, BlackBerry dev alpha
My Carrier: Airtel

Re: Erro with Webworks Archive when packaging

Use winrar to zip your webwork files
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: Erro with Webworks Archive when packaging

It seems like some entry are incorrect in your .properties file. You need to add your webworks SDK path, sign key, password etc 

Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
Trusted Contributor
Posts: 166
Registered: ‎12-09-2011
My Device: 9550,9300,9800,9700,9900,9850,9860

Re: Erro with Webworks Archive when packaging

I think there is some problem in your Package or in Config.xml file.
Check once in Config.xml. 

Thanks & Regards,
Nitish Subudhi

Feel Free To Press The Like Button On The Right Side To Thank The User That Helped You.
Please Mark Posts As Solved If You Found a Solution.