Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 97
Registered: ‎11-13-2012
My Device: BB10 Simulator
My Carrier: Globe Telecom
Accepted Solution

Error: Failed to decrypt keystore, invalid password - requested new keys (still the same)

Any suggestions guys? I was able to sign android apps before, now I am trying to sign apps using webworks. I got a new key then followed everything here: https://developer.blackberry.com/html5/documentation/signing_setup_bb10_apps_2008396_11.html

 

Still the same error. over 5 keys requested already, and different pins for every request. Still now luck. I have a fast internet too. Smiley Sad

Developer
Posts: 97
Registered: ‎11-13-2012
My Device: BB10 Simulator
My Carrier: Globe Telecom

Re: Error: Failed to decrypt keystore, invalid password - requested new keys (still the same)

Anybody can help me please?

BlackBerry Development Advisor
Posts: 767
Registered: ‎10-01-2009
My Device: All
My Carrier: N/A

Re: Error: Failed to decrypt keystore, invalid password - requested new keys (still the same)

Hello,

 

There are a few threads dealing with solutions to this.  Here's one that has helped others:

 

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Cannot-register-keys/m-p/2000565...

 

Developer
Posts: 97
Registered: ‎11-13-2012
My Device: BB10 Simulator
My Carrier: Globe Telecom

Re: Error: Failed to decrypt keystore, invalid password - requested new keys (still the same)

Just got it working now. I found another p12 something file in the Research In Motion folder, deleted my author.p12 and replaced it with the other, and renamed the other to author, and now it perfectly works.

 

Thank you bro.