Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
Regular Contributor
Posts: 63
Registered: ‎08-05-2013
My Device: Blackberry-10 webworks
My Carrier: zcon
Accepted Solution

Error while packaging the app using Ripple Emulator

Hello All, I am using Ripple Emulator for packing the app for blackberry 7os using Blackberry Webworks 2.3.1.5 SDK.

When I click on package button I am getting error as follows:

 

Build request failed with message: Error: ENOENT, unlink 'C:\Documents and Settings\AtikJ\RippleSites\HelloWorld\PKG\HelloW.zip'

 

 

So please suggest me some solutions...

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Error while packaging the app using Ripple Emulator

Can you please confirm which version of Java you have installed? Specifically this will be under the following folders:
- C:\Program Files\Java
- C:\Program Files (x86)\Java

If you could provide the full list of sub-folders that appear under those folders that will give us an idea of the Java version you are using. Also, is your PC 32-bit or 64-bit?

Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Regular Contributor
Posts: 63
Registered: ‎08-05-2013
My Device: Blackberry-10 webworks
My Carrier: zcon

Re: Error while packaging the app using Ripple Emulator

Thanks for your reply..
My machine is 32 bit machine..Also I am using JDK 1.7.....

I have solved this issue..
We need to specify path of our webworks SDK in the settings option of ripple emulator.
So in the path of SDK there should not be any space charater..
i.e. c:/Program Files/Research In Motion/..... this is invalid.

c:/ResearchInMotion/BlackberrySDK2.3.1.5...this is correct.

 

Another thing i have done is in the bbwp.properties file located in bin directory of webworks SDK...I have provided correct path of JDK. Also I have set environment variables.

 

After performing these steps cod and alx files are generated.

 

Contributor
Posts: 20
Registered: ‎06-06-2013
My Device: BlackBerry Curve 9320
My Carrier: Vodacom

Re: Error while packaging the app using Ripple Emulator

My SDK setting  - C:\Program Files\Research In Motion\BlackBerry WebWorks SDK 2.3.1.5 and the first attempt with Ripple I managed to package HELLOWORLD successfully.

 

I've gone on to the WEATHER sample app with the folder located at C:\Users\Marc\RippleSites\Weather. I've encountered a problem packaging.The error message reads - 

 
 Oh Snap! Build request failed with message: Error: ENOENT, unlink 'C:\bbosarchive\WeatherFinal.zip'

 

With the SDK setting  - C:\ResearchInMotion\BlackBerryWebWorksSDK2.3.1.5

The error message reads 
Oh Snap! Build request failed with message: C:\ResearchInMotion\BlackBerryWebWorksSDK2.3.1.5 is not a valid path


Oh Snap! Build request failed with message: C:\ProgramFiles\ResearchInMotion\BlackBerryWebWorksSDK2.3.1.5 is not a valid path

 

This my bbwp.properties 

<?xml version="1.0" encoding="UTF-8"?>

<wcp>
<rapc>bin\rapc.exe</rapc>
<jar>lib\net_rim_api.jar</jar>
<wcp_template>device_templates</wcp_template>
<java>C:\Program Files\Java\jdk1.6.0_39</java>
<additional>-quiet</additional>
<extension_repository>ext</extension_repository>
</wcp>

 

Thanx upfront

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Error while packaging the app using Ripple Emulator

Hi Marc,

 

It seems the spaces have been stripped out in the output logs for the SDK path; can you confirm that this is indeed correct? If so, the packager is likely not finding the SDK properly.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.