Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Member
Posts: 1
Registered: ‎06-30-2012
My Device: Blackberry Curve
My Carrier: T-Mobile

Errors when packaging HTML5 app for SmartPhone

Hi,

 

I am using Windows Vista and trying to compile an HTML5 app I created using the SmartPhone SDK from the command line. I get the error below. I tried running this using an administrator cmd prompt but it did not fix the problem. It also happens when I tried to package the demo apps.

 

[INFO]                  Parsing command line options
[INFO]                  Parsing bbwp.properties
[INFO]                  Validating application archive
[INFO]                  Parsing config.xml
[INFO]                  Populating application source
[INFO]                  Compiling BlackBerry WebWorks application
javac: invalid flag: ~1AppDataLocalTemp
apc_76878cb6.dir
Usage: javac <options> <source files>
use -help for a list of possible options
Error!: Error: java compiler failed: C:\Program Files\Java\jdk1.7.0_03\bin\javac
.exe @C:\Users\AVIMA~1\AppData\Local\Temp\rapc_76878cae ...
[ERROR]                 RAPC exception occurred

Developer
Posts: 435
Registered: ‎09-20-2011
My Device: Z10 LE, Playbook, DevAlpha C, 9900, 9380
My Carrier: Vodafone

Re: Errors when packaging HTML5 app for SmartPhone

just try to reinstall your jdk............... And check your compuetrs environmental variable have the path of jdk.

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Errors when packaging HTML5 app for SmartPhone

>> RAPC exception occurred

 

This tells me that an error occured while trying to compile some Java code.  The reasons for this could be:

1) A custom extension is trying to be compiled that has a syntax error in it.

2) the WebWorks SDK did not fully install correctly.  Try re-installing to correct this problem.

3) The Java SDK installed is not compatible. Check requirements here.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.