Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 442
Registered: ‎08-02-2010
My Device: Z10
My Carrier: Telus
Accepted Solution

Errors when trying to compile WebWorks app

Hi all. Can someone help me solve these compie errors I receive when trying to build with Ripple?

 

[INFO] Packaging the bar file
javax.imageio.IIOException: Can't read input file!
at javax.imageio.ImageIO.read(Unknown Source)
at net.rim.tumbler.airpackager.AirPackager.createSplashscreen(AirPackager.java:723)
at net.rim.tumbler.airpackager.AirPackager.run(AirPackager.java:191)
at net.rim.tumbler.WidgetPackager.go(WidgetPackager.java:152)
at net.rim.tumbler.WidgetPackager.main(WidgetPackager.java:77)
[ERROR] Air Packager exception occurred

 

I made sure my JRE is 32 bit, I added the System path to the /bin.

 

My Config is below:

 

<?xml version="1.0" encoding="utf-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
        xmlns:rim="http://www.blackberry.com/ns/widgets"
        version="2.0.0.0">
 
  <author href="http://www.example.com/"
          rim:copyright="Copyright 1998-2012 My Corp">none</author>
 
  <name>Sample application</name>
 
  <description>
    A sample application to demonstrate some features.
  </description>
 
  <rim:orientation mode="auto"/>
 
  <rim:loadingScreen backgroundImage="bg.png"
                     foregroundImage="fg.png"
                     onLocalPageLoad="true">
    <rim:transitionEffect type="zoomIn"/>
  </rim:loadingScreen>
         
  <rim:category name="games"/>    
 
  <rim:permissions>
    <rim:permit>access_shared</rim:permit>
    <rim:permit>read_geolocation</rim:permit>
    <rim:permit>use_camera</rim:permit>  
  </rim:permissions>
 
  <icon src="icon.png"/>
 
  <content src="index.html"/>
 
  <feature id="blackberry.ui.dialog"/>
 
  <access uri="http://www.somedomain.com" subdomains="true">
    <feature id="blackberry.app.event"/>
    <feature id="blackberry.invoke"/>
  </access>
 
</widget>

 I've read all the threads re: the same problem but nothing I've tried has worked.

 

Highlighted
Developer
Posts: 134
Registered: ‎05-19-2012
My Device: Torch 9800, PlayBook 64GB, Dev Alpha
My Carrier: VIVO Brazil

Re: Errors when trying to compile WebWorks app

Looks like your problem is because the WebWorks packager isn't able to open some of your image files, double check if there's any missing and make sure the permissions to read the files are correct.

I've had similar problems with the WebWorks packager and I solved them by running it as root.
If I helped you please click the "Like" button to support my work.
My apps: CherryNotes - Bookmarked - Requests
Social Me: about.me - Twitter
Developer
Posts: 442
Registered: ‎08-02-2010
My Device: Z10
My Carrier: Telus

Re: Errors when trying to compile WebWorks app

Ahh thanks will try compiling as administrator tmw via cmd prompt rather than Ripple. Will let you know. 

Developer
Posts: 442
Registered: ‎08-02-2010
My Device: Z10
My Carrier: Telus

Re: Errors when trying to compile WebWorks app

Using your suggestions I got it to compile. I should also mention (in case anyone else has run into this problem) I was forgetting to change the project root settings when going between applications so that's what was causing the missing image file path errors.