Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 119
Registered: ‎05-27-2010
My Device: 9900
My Carrier: Vodafone NL

External JavaScripts not being loaded (in PlayBook WebWorks)

Dear BlackBErry Support forum,

 

I tend to create the following file structure for any of my WebApps:

 

CSS

CSS0001.css

IMG

img1.png

img2.jpg

JS

JS0001.js

JS0002.js

SND

snd1.mp3

VID

vid1.mp4

 

index.html

(config.xml)

 

When trying to run the WepApp after packaging with the WebWorks Packager and deploying it on the PlayBook simulator, none of the JavaScripts files are loaded that are stored in the JS directory, when running the WEbWorks application. Funny thing is the same WebApp works perfectly through the browser on teh PlayBook.

The CSS files do load.

 

this is how the files are included:

<script src='JS/JS0001.js' type='text/javascript'></script>

 

It is used in the header to included the JavaScript file(s).

 

When renaming it all to small letters, the JavaScript files do load.

 

This seems a bug in either the WebWorks Packager or WebWorks run-time, but I'd like to confirm before entering a issue.

 

Many thanks for your feedback.

@reumerd-- @BBDevGroupNL -- about me
If you like it, LIKE it ;-) ----- If it's solved, press solved ! --- If you solved it yourself, please let us know! We might have the same problem!
Highlighted
Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: External JavaScripts not being loaded (in PlayBook WebWorks)

Thanks Dennis,

 

I'll report the issue to the Development team.. 

 

Cheers

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter