Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 3
Registered: ‎07-26-2011
My Device: BlackBerry Tour 9630
My Carrier: Verizon
Accepted Solution

Failed to find config.xml

Hello all,

 

I've searched the forum and Googled my issue with no luck.  Hopefully someone here can help me.

 

On my Windows XP VM, I am trying to use the WebWorks packager to compile an archive file.  Everytime I do, I get "invalid archive - failed to find config.xml".  My zip file of course HAS a config.xml.

 

While trying to resolve the problem myself, I downloaded the sample sketchpadStandard.zip and was able to compile that with no errors.  I extracted the file and re-zipped it and got the "failed to find config.xml" error.  I have used the windows XP utility, I have downloaded winzip and used that utility, I have used my mac to compress the file.  Each time *I* do it, I get the error. 

 

Clearly, the packager works, and I am in the correct directory as I am able to compile the provided sample archive, but why the heck can't I compile the VERY SAME FILES that I have archived myself?

 

Any thoughts much much appreciated.

 

New Contributor
Posts: 3
Registered: ‎07-26-2011
My Device: BlackBerry Tour 9630
My Carrier: Verizon

Re: Failed to find config.xml

And forgot to mention this is the packager for tablet.  Thanks.

New Contributor
Posts: 3
Registered: ‎07-26-2011
My Device: BlackBerry Tour 9630
My Carrier: Verizon

Re: Failed to find config.xml

After several hours of experimenting, I finally loaded the mac version of the SDK straight on my mac, rather than the windows version on my Windows VM.  I followed the fix here that was to fix the same problem on a mac, and it worked.

Visitor
Posts: 1
Registered: ‎12-29-2011
My Device: Playbook
My Carrier: ATT

Re: Failed to find config.xml

This is no solution.  I am using a Windows 7 machine.  I should be able to make the archive on this machine  NOT on another machine.  That will be solution of the problem !!!