Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 3
Registered: ‎08-05-2013
My Device: BB Z10
My Carrier: vodafone

Help Me Please????

My problem is :

I have made a web application in which I have embeded flash game i.e game.swf file.

Now the flash file i.e game.swf file is internally showing Ad's from inneractive which works fine on Nokia as well as on desktop while cheking but does not work on BB10. Please help me.

 

my config.xml is::

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
    xmlns:rim="http://www.blackberry.com/ns/widgets"
    version="1.0.0.0" id="ndv">   
   
    <name>ndv</name>
    <author>Ei</author>
    <description>Stion</description>
 <feature id="fc">
    <param name="websecurity" value="disable" />
  </feature>    
<rimSmiley Tongueermissions>
    <rimSmiley Tongueermit>access_shared</rimSmiley Tongueermit>
<rimSmiley Tongueermit>access_internet</rimSmiley Tongueermit>
      </rimSmiley Tongueermissions>
    <icon src="images/icon.png"/>
    <content src="index.html"/>
<feature id="enable-flash"/>
<feature id="blackberry.app">
    <param name="orientation" value="landscape" />
</feature>
<access uri="http://m2m1.inner-active.com" subdomains="true">
     <feature id="blackberry.app" required="true" version="1.0.0"/>
    <feature id="blackberry.invoke" required="true" version="1.0.0"/>
</access>
<access subdomains="true" uri="*"/>
</widget>

 

 

-- IS there any permission I have to give.

Inside flash file. I have xml object which catches the data which is return by the server.

the code snippet inside the flash file is is:

 

xmlObj.load("http://m2m1.inner-active.com/simpleM2M/clientRequestHtmlAd?aid=Ea&v=Sm2m-2.1.0&po=551&test=1&w=360&h... "POST");

 

 

-Please please help as I want it urgent. Thanks in advance.

BlackBerry Development Advisor
Posts: 762
Registered: ‎10-01-2009
My Device: All
My Carrier: N/A

Re: Help Me Please????

You could try to disable web security. Usually we just whitelist domain names, but seeing as it's an ad network you may be best to just disable web security in general. 

 

Looks like you've got it in your config, but the wrong 'id'.

 

<feature id="blackberry.app">

   <param name="websecurity" value="disable" />

</feature>

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Help Me Please????

Can you please confirm whether chadtatro's suggestion resolved the issues?

If you are still seeing issues, can you check Web Inspector to confirm whether there are any errors arising or network transmission issues? Are you seeing any errors in particular arising? (i.e. specific text)

As Chad noted, it's likely due to the application reaching out to external URLs that haven't been white-listed. Disabling web security should give you a blanket "allow" for all URLs.

Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.