Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Regular Contributor
Posts: 77
Registered: ‎06-02-2012
My Device: Playbook, BB10
My Carrier: Orange

Inspector Broken in last BB10 update

Hello,

 

Since the last BB10 update, the web inspector is broken and very, very laggy.

When I try to inspect a div it stalls for ten seconds or so and then a black picture(as attached) appears on phone's screen.

After another 10 seconds or so the black image disappears and if I want to inspect another div I have to repeat this process, if the app doesn't hang, which happens in 90% of the cases right after the black image appears initially.

This happens when I use the latest bbUI 0.9.5.10, latest (gold) webworks sdk and the latest version of bb10 os 10.0.9.1675 . But I believe it has nothing to do with the my app or webworks sdk, it's related to the latest update of bb10 os. On my friend's BB10 phone who hasn't updated yet to 1675 the inspector and my app work fine.

Please someone verify this and report as bug if necessary.

 

Regards,

Andrei Avram

IMG_00000027.png

I've tried this wit

Contributor
Posts: 11
Registered: ‎09-01-2012
My Device: Z10 / PlayBook
My Carrier: Telus

Re: Inspector Broken in last BB10 update

I have seen the same thing with my testing.  Black screen with newest everything (BBUI.js 0.9.5, Gold SDK and 1675 Dev Alpha). I can still use the console and the javascript debugging, but when I try inspect elements of the page the black screen appears.

Developer
Posts: 30
Registered: ‎12-15-2012
My Device: Z10 LE, Playbook and Dev Alpha C
My Carrier: BASE

Re: Inspector Broken in last BB10 update

[ Edited ]

Same thing for me, really annoying and sometimes the whole screen gets messed up showing pixels in random colors and white squares and stuff. Besides that rendering of webfonts is now incredible slow and they also look kinda screwed was no problem with the dev alpha firmware before the gold sdk. 

 

Edit: Here are some sample images.

 

www.ImageBanana.com - IMG_00000004.pngwww.ImageBanana.com - IMG_00000006.png

Regular Contributor
Posts: 77
Registered: ‎06-02-2012
My Device: Playbook, BB10
My Carrier: Orange

Re: Inspector Broken in last BB10 update

[ Edited ]

I've also noticed white squares above some pages whe usign bbUI, I don't know if the bugs are related, but I noticed that these white squares looked like that part of the screen was not "refreshed", I mean that I could use the underlying controls "blindly", like the back button, even if I didn't seen it.

Anyway, today I couldn't reproduce the white squares, that is my least concern.

The problem with the inspector is really bad because, I really can't rely on Ripple to inspect and debug; maybe someone from RIM could test this soon and let us know a workaround if any or update the OS.

 

EDIT: I constantly get random colored squares on html5test.com, they seem to change position and colour if I put the phone in stand-by and get it out of stand-by.

 IMG_00000029.png

New Contributor
Posts: 8
Registered: ‎12-16-2012
My Device: PlayBook
My Carrier: Virgin Mobile

Re: Inspector Broken in last BB10 update

Yep, I get the same issue. As soon as I try to expand any HTML nodes the screen goes black or I get that 'body px px' text.

Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Inspector Broken in last BB10 update

Same issues here after last update of BB10 OS.

Inspecting the HTML content of an app is really broken. I got black screens when selecting an HTML node in the Inspector and it seems the app becomes unresponsive, some seconds later it might or might not show the source of the selected HTML node together with its attributes.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Highlighted
Retired
Posts: 165
Registered: ‎09-24-2012
My Device: Passport
My Carrier: Bell

Re: Inspector Broken in last BB10 update

All,

 

We are currently investigating an issue with Web Inspector when using the Elements tab. Thank you for your patience.

Developer
Posts: 30
Registered: ‎12-15-2012
My Device: Z10 LE, Playbook and Dev Alpha C
My Carrier: BASE

Re: Inspector Broken in last BB10 update

Any progress? Would be nice if we can have a fix before the launch. 

Developer
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha
My Carrier: o2 (de)

Re: Inspector Broken in last BB10 update

+1 for non-refreshing content and broken scrolling.

 

See me forum post (with videos): http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Scrolling-problems-with-current-...

- - -
My approved apps @ App World
Regular Contributor
Posts: 77
Registered: ‎06-02-2012
My Device: Playbook, BB10
My Carrier: Orange

Re: Inspector Broken in last BB10 update

No update on this bug? 

The deadline is approaching fast and development is very slowed down because of this bug. Please issue an update soon.